Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PSCX2 crashing on Ubuntu 13.10
#1
Running latest KDE, latest Nvidia drivers (tried both 331.32 release and 334.16 beta). Pcsx2 1.1, 1.2.2 and 1.3.0.0 (from SVN). When I try to configure GSDX, pcsx2 just closes. All that is logged in the console is "Killed"....not very useful. I've tried different gtk2 thtmese as well, no help.

If I try to start a game, I get the following err message:

Code:
/home/gregory/playstation/emulateur/svn/branches/1.2.x/common/src/Utilities/Linux/LnxHostSys.cpp(64) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    MTGS
    Condition: false
    Message:   Unhandled page fault @ 0x0000000e

Stacktrace:
[00] 0x0xf777d410                                
[01] GSDeviceOGL::SetupPS(GSDeviceOGL::PSSelector)
[02] GSRendererOGL::DrawPrims(GSTexture*, GSTexture*, GSTextureCache::Source*)
[03] GSRendererHW::Draw()                        
[04] GSState::FlushPrim()                        
[05] void GSState::GIFRegHandlerFRAME<0>(GIFReg const*)
[06] void GSState::Transfer<3>(unsigned char const*, unsigned int)
[07] GSgifTransfer


I can run things with zzogl but it is slow and has quit a few rendering errors. I tried the following manual dsgx ini edit's as well, all to no avail:

Code:
override_GL_ARB_separate_shader_objects = 0
override_geometry_shader = 0


Any help would be appreciated.
Reply

Sponsored links

#2
PCSX2 can be stubborn at times. You can try deleting the gsdx.ini file and try running the game a few more times. Eventually it will work. Or start the game in software mode then change it to hardware mode. Both strategies worked for me with my new 650 Ti. Now I don't have to do any fancy stuff now. It just works.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
I think the issue is the default renderer. Just open gsdx gui select opengl, save. And retry. Note reverse your modification.
Reply
#4
(03-05-2014, 09:20 AM)gregory Wrote: I think the issue is the default renderer. Just open gsdx gui select opengl, save. And retry. Note reverse your modification.

(03-05-2014, 05:22 AM)DaTankAC Wrote: PCSX2 can be stubborn at times. You can try deleting the gsdx.ini file and try running the game a few more times. Eventually it will work. Or start the game in software mode then change it to hardware mode. Both strategies worked for me with my new 650 Ti. Now I don't have to do any fancy stuff now. It just works.

Thanks guys.

When I try to open the plugin onfiguration, PCSX2 just closes so my only option is to edit the ini file. However, I removed the file and am able to run a game, but the GS is at 100% and my framerate is useless. Maybe there is a setting I can manually change to allow access?
Reply
#5
In this case, set renderer to 12 in GSdx.ini. However the crash is not normal. Maybe try a different set of plugins.
Reply
#6
(03-06-2014, 12:18 AM)gregory Wrote: In this case, set renderer to 12 in GSdx.ini. However the crash is not normal. Maybe try a different set of plugins.

It's already set to 12. Apparently it defaulted to that after deleting the ini the last go around. I referred to a backup of the ini I saved before deleting it and found it was previously set to 13. This is probably why I can at least run a game now (albiet in a useless fashion).

As far as a different set of plugins, I'm not sure what you mean. The only plugins that I can change are the CDDVD ones (which I changed to no avail) and the GS to zzogl which is slow and buggy. I found this one laying on an old 1.0.0.0 folder from a while ago. The current zip doesn't have that one any more.

If you are referring to the GSDX plugin version, I looked over my system and the only gsdx I can find are 0.1.16. A quick search in the downloads section here on the site yeilded little in the way of older plugins. The only single downloads for GSDX are widows only packs. I pulled some older archived version of the full archive for linux, they don't start shipping with gsdx until 1.0.0.0, but this is the same version: 0.1.16.

I apoligize for the lengthy reply. I just want to be as clear as possible.
Reply
#7
So the freeze only appears with GSdx plugin. I need to test trunk with latest nvidia hardware.
Reply
#8
(03-06-2014, 10:31 AM)gregory Wrote: So the freeze only appears with GSdx plugin. I need to test trunk with latest nvidia hardware.

I heard there were some debug builds around. Maybe I can run one of those so that I get more info to you other than a simple "killed" message. If you could tell me what I need to do, I'm sure I can get you some helpful info.
Reply
#9
Which version of libc6 do you have? One is very buggy and crash GSdx.
Reply
#10
(03-07-2014, 09:41 AM)gregory Wrote: Which version of libc6 do you have? One is very buggy and crash GSdx.

This is what libc.so.6 dumps from /lib32:

Code:
GNU C Library (Ubuntu EGLIBC 2.17-93ubuntu4) stable release version 2.17, by Roland McGrath et al.
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
Compiled by GNU CC version 4.7.3.
Compiled on a Linux 3.11.3 system on 2013-10-12.
Available extensions:
        crypt add-on version 2.1 by Michael Glad and others
        GNU Libidn by Simon Josefsson
        Native POSIX Threads Library by Ulrich Drepper et al
        BIND-8.2.3-T5B
libc ABIs: UNIQUE IFUNC
For bug reporting instructions, please see:
Reply




Users browsing this thread: 1 Guest(s)