Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PSX2 1.40: Doesn't work on WinXP (SPU2 DLL not recognized)
#1
Yes, I know, Windows 7 is the greatest thing ever and everyone on the planet should be using it (or newer), and I'm a huge dumb-ass for using an OS that no longer has Microsoft's blessing.

Now that we have that out of the way...

I downloaded PSX2 1.4.0 binary archive from this site and unpacked it to my external drive. I downloaded the Windows XP SPU2 DLL from the plugins page and unpacked it to the plugins directory. I downloaded and installed the VC 2015 runtime files from the link provided (Microsoft).

When I run PSX2, the SPU2 box on the plugins screen is empty and the Configure button is grayed out. It won't let me go past this screen without having the plugin box filled. I tried renaming "SPU2-X_WinXP-VS2013.dll" to "SPU2-X.dll", but that doesn't work either. I tried downloading PSX2 1.2.1 and copying the plugins from that version to the 1.4.0 directory, but that didn't work either.

I'll paste the log file below, but it really doesn't say much. The whole thing is in a directory on my external drive, so file permissions shouldn't be a problem. I have tried running it as Administrator and that didn't work either. So my question is; Can PSX2 still be run under Windows XP, SP3? If so, how?

Log;


Code:
Path: g:\Temp\PCSX2 1.4.0\Plugins\cdvdiso.dll
File is not a valid dynamic library.
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\cdvdiso.dll' (error 126: the specified module could not be found.)
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\cdvdiso.dll
Path: g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
File is not a valid dynamic library.
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx.dll' (error 5: access is denied.)
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
Path: g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx2.dll
File is not a valid dynamic library.
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx2.dll' (error 5: access is denied.)
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\gsdx32-avx2.dll
Path: g:\Temp\PCSX2 1.4.0\Plugins\padPokopom.dll
File is not a valid dynamic library.
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\padPokopom.dll' (error 126: the specified module could not be found.)
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\padPokopom.dll
Path: g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X.dll
File is not a valid dynamic library.
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X.dll' (error 126: the specified module could not be found.)
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X.dll
[wx] Failed to load shared library 'g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X_WinXP-VS2013.dll' (error 126: the specified module could not be found.)
Path: g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X_WinXP-VS2013.dll
File is not a valid dynamic library.
Some kinda plugin failure: g:\Temp\PCSX2 1.4.0\Plugins\SPU2-X_WinXP-VS2013.dll
Action canceled: Startup aborted: User canceled FirstTime Wizard.
Reply

Sponsored links

#2
Has been discussed here : http://forums.pcsx2.net/Thread-Cannot-Se...#pid501718
not sure exactly how it works, though.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
are you trying to run PCSX2 from the archive? You need to extract it first.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
PCSX2 1.4 requires VC 2015 and that plugin alone requires VC 2013,do you have vc 2013 installed(x86/x64....I don't know which is needed based on the OS type)
Reply
#5
(03-19-2016, 11:36 PM)refraction Wrote: are you trying to run PCSX2 from the archive? You need to extract it first.

No, as I stated in my first message, I unpacked it to my external drive.

(03-20-2016, 05:43 AM)vsub Wrote: PCSX2 1.4 requires VC 2015 and that plugin alone requires VC 2013,do you have vc 2013 installed(x86/x64....I don't know which is needed based on the OS type)

Thank you, that's what I was missing!

It works now. I've only tried one game so far, Godzilla: Save the Earth, but it seemed to run at a playable speed. It stuttered a little and the audio seemed a little slow, but I played a vs. match and didn't have any real problems with it. I haven't tweaked any of the settings yet though, I basically just configured a controller and booted the game to see if it would work. To be clear, I'm not complaining. I knew beforehand that my system (2.4Ghz Core-2-Duo) might not be able to run PSX2 at full speed.

In any case, it performs much better on my system than Dolphin, the Gamecube emulator. That one is only playable if I disable the sound, and who wants to play silent games?

Anyway, thank you again. Smile
Reply




Users browsing this thread: 1 Guest(s)