Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pcsx2 beta (1888) errors
#1
Question 
One lovely week into FFX - the game crashes at Djose Temple. I had been forewarned of this, and now it has happened. From searching, the apparant solution is to run the game on the PCSX2 beta (1888). I had previously been using 0.96.

...And a new emulator, new problems. And it took hours to figure out the last one too...

There are several issues this time, which of them is the problem, I'm not sure. For one, there is an error reading d3dx10_42.dll file, although it is in my Windows System 32 folder already. Also, with the new emulator, some of the old plugins are unavailable. For some reason, the only keyboard plugin that seemed to work was Twinpad in the earlier version. However only Lilypad is available here, and I'm having the same difficulty configuring it. On top of that, the only CDVD plugin that worked was P.E.Op.S (CDDA mod). I am using an ISO image mounted onto a virtual disk, and no other CD plugin could read it. It was the same when I tried Linuz ISO and tried to have it run the ISO directly. Which happened to be the only option available.

I've tried moving the old plugins to the new plugin folder and running them. Whether they are compatible or not I'm unsure, but as of the moment the CD is not running (Twinpad is functioning).

All advice would be greately appreciated.
Reply

Sponsored links

#2
First of all: Can you provide a memory card with a savefile close to that crash? Thanks.

Second:
-Download and run the latest directx updater
-Lilypad works just fine on the 1888 beta, you'll need to work out the config. It's not so hard, really Tongue2
-Don't mount the iso with deamon tools. Just use Linuz cdvd, and run the iso with it
Reply
#3
(09-26-2009, 02:12 AM)rama Wrote: First of all: Can you provide a memory card with a savefile close to that crash? Thanks.

Second:
-Download and run the latest directx updater
-Lilypad works just fine on the 1888 beta, you'll need to work out the config. It's not so hard, really Tongue2
-Don't mount the iso with deamon tools. Just use Linuz cdvd, and run the iso with it


Save file in the attatchment. It should be on the highest number slot used.

-I've re-download and updated the updater several times, however the error message keeps popping up. "...d3dx10_42 is either not designed to run on windows or contains an error. Try installing the program again or..."
-Do you have any suggestions on the input method to use? I'm using a wireless USB mouse/keyboard on a Vista system.
-I have already tried it, but an error message that reads "Error opening CDVD Plugin" always comes up.
Reply
#4
Make sure you dont have the ISO mounted on another program when running it from the Linuz ISO cdvd plugin.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
-I don't see any attachments ><
-Right, Linuz iso stops working as soon as anything accesses the iso. Even in read only mode.
-Input method will be default (Windows messaging and Direct Input)
-Did you manually copy the d3dx10 dll around?
Reply
#6
Right, I also got the error on that DLL file. But with a little googling I discovered an August DirectX update. I installed that, and it fixed the problem (Probably only relevant on vista/win7). If you manually downloaded the DLL, then it will need to be registered. But it is probably better just to use the true blue DirectX update package.
Reply
#7
(09-26-2009, 01:46 PM)rama Wrote: -I don't see any attachments ><
-Right, Linuz iso stops working as soon as anything accesses the iso. Even in read only mode.
-Input method will be default (Windows messaging and Direct Input)
-Did you manually copy the d3dx10 dll around?

-Having some trouble getting the attatchments to work; Sorry about that, I'll see if I can try to get it on another post
-Oh, so even if I run the file directly, if I mounted it using another program first, it won't work... I'll go try it now
-I've tried both input methods, but as soon as I click "Apply", both my mouse and keyboard freeze up.
-I've tried both manually copying it, and using dxwebsetup
Reply
#8
So here's the memcard. I'm not sure how to work the attatchments (the file just disappears when I hit "add attachment", so just foud a file uploading site...

[LINK]
Reply
#9
NEW UPDATE:

-I can now successfully launch and play the game
-Twinpad is functional on the beta
-Linux is working fine now

The only problem that still remains - the graphics are cracked due to the DX error.
Reply
#10
You didnt answer, did you copy the .dll file manually? if you did try deleting it and running the Directx August 2009 Redistributable.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)