Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pcsx2 lag problem
#1
Laptop: Acer Aspire 5738ZG
Specs: 500gb SATA hdd, intel pentium dual core 2.0ghz, 4gb ram dd3, Nvidia Geforce G105M 512mb.

Hello there
I have a problem using pcsx2 0.9.6.
When i first start playing pcsx2 it has full speed (60fps) and all well so far. Then after playing for a little while the program starts lagging down to 35-50 fps and it keeps that low for about 5 minutes, then goes back up to 60 fps, and then after a little more while it starts lagging the same again, then goes back up to 60fps and onward like this. it keeps repeating itself and im not cooling down the pc when it goes back up from lagging. Im wondering what might be the cause of this problem?
This happens on 3 games that i have tested:
- Final Fantasy X
- Kingdom Hearts 1
- Kingdom Hearts 2
Using Windows XP pro service pack 2
This problem started to happen after i got my pc back from the repairation store to change my hdd, before that the game allways ran at 60fps no problem. I have everything installed, newest directx10 and graphic driver.
PS: I changed sata mode from AHCI to IDE to install winxp on my pc, may that have been the cause of the problem?

Sponsored links

#2
with XP you can't have DX10.. but use the latest beta
#3
Ive tried using latest beta, lagged even worse....
forgot to write this in, ive tried on windows 7 too, same problem there
#4
(06-17-2010, 11:48 PM)ltfk93 Wrote: Ive tried using latest beta, lagged even worse....
forgot to write this in, ive tried on windows 7 too, same problem there

did you select on native mode in gsdx to see if the lag goes away and also try using speed hacks, it might speed up a bit.

But even if you did that you wont get that much of a difference in fps because of your computer speed and possibly your graphics card.
CPU: Core i5 Processor 3330
GPU: EVGA GTX 970 FTW 4GB
RAM: 16 GB
HDD: 1 TB
OS1: Windows 10
#5
Are you running any other programs that could be using your processor or a lot of writing to your hard drive?
#6
could it be that "speed step" or something energy related from the bios or windows ?
#7
Well im not using the beta version so cant really say anything there, and no i turn all the programs off including wireless net when i use pcsx2 i even tried going on advanced tab on my computer, and adjust it to best performance. This is really irritating for me since i know the pc can run games at 100% as it did that before, but now i get this lag problem repeating itself.
Im starting to think that something is wrong with my graphic card
edit: yes ive tried using all speed hacks ( 3X and all 3 options on the right side) even tried VU skip on cpu
remember im using pcsx2 0.9.6
#8
In this case, buy a new graphic card, overclock your cpu, or attempt a full system recover, which i advise you to backup your files in case it gets worse.

But if what your saying is true that it can run 100 percent as it did before, then there could be a virus on your computer.
CPU: Core i5 Processor 3330
GPU: EVGA GTX 970 FTW 4GB
RAM: 16 GB
HDD: 1 TB
OS1: Windows 10
#9
one problem with that suggestion dog, im using a laptop and its hard to find a new graphic card for it-.- and my bios is for some reason limited:/ i cant configure or overclock anything there, only basics. This laptop still has 2 and a half year of warranty so i can forget buying new laptop parts for a long while....
Might just deliver it and ask it to get replaced.
Yes by the way im not sure i mentioned it, I switched SATA mode from AHCI to IDE to install winxp...may that be the problem?
i allways forget to write the last part-.-
im not sure about a virus problem but it might be true as the external with all the ps2 games has around 1k virus...(yeah im not kidding)
#10
Hmm...switched sata from ahci to ide to install winxp..

That could possibly be the problem. Try it out. You don't know what the solution is until you try everything.
CPU: Core i5 Processor 3330
GPU: EVGA GTX 970 FTW 4GB
RAM: 16 GB
HDD: 1 TB
OS1: Windows 10




Users browsing this thread: 1 Guest(s)