Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 FES Slowdown on Certain Enemies
#1
Been trying to play P3 and ran into some problems.
The game works fine most of the times and the fps is pretty good for the most part but a few bosses and enemies drop the FPS by a ton. Any way to fix this?
Reply

Sponsored links

#2
Getting a better PC maybe?

There are a few known monsters that slow down a lot the emulator and since you didn't post your PC specs, PCSX2/Plugin settings or posted a screenshot of the game window when you get the slowdown there's not much we can help with.

try the latest beta if you aren't already:
http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I'm having the same problem, but this applies to most monsters I encounter. The frame rate sometimes drops to around 20~30 fps, and I'm playing at 640x480 resolution. Currently using Dual Core 5200 2.50Ghz CPU, ATI 3450 256 MB (I know, very sad) with 3GB RAM. Default PCSX2 settings.
Is this normal for specs like mine?
Also, I'm thinking of buying a new computer: i3 540 3.06 Ghz, ATI 5770 1GB and 4GB of RAM. I would assume the new one won't have any slowdown problems on this game and Persona 4? The monitor's resolution would be 1600x900, so if there's no slowdown even at that resolution, even better.
Reply
#4
It's normal, some of the monsters slow down a lot. The new computer should be much better, still slowing down but not so much.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
The slowdown happends with monsters like special/gold hands or monster with reflection textures.

I bypassed the problem by checking "use original ps2 resolution" (you will not have the enanched graphic but the game will run smooth like a charm.)
Reply
#6
(01-06-2011, 04:05 PM)3xistence Wrote: The slowdown happends with monsters like special/gold hands or monster with reflection textures.

I bypassed the problem by checking "use original ps2 resolution" (you will not have the enanched graphic but the game will run smooth like a charm.)

Oh god, I already check that box even before I posted on this forum. The slowdown happens with that box checked.
Probably just my computer...
Reply
#7
how about mine i also got 30~40 fps slowdown on some monsters but not only monster also some specific spot/locations too
im using the verly latest pcsx2 beta 0.9.7(r3878)
SSE4 (gsdx9)(hardware)(native)
and i have already tried diff speedhacks "combos"
still nothing change i enable the VU clip hack gamefix (says Persona games and Super VU) others are set to defaults.

My specs:
Intel i3 530 3.5Gghz (overclocked)
ATI HD 4650 1GB DDR2
2GB RAM DDR3
Windows XP SP3

i dont really get it why i got those slowdowns when i have already overclocked my procie.


Attached Files Thumbnail(s)
       
Reply
#8
That's because some games / scenes overburden even the fastest machines.
No one said you'd get full speed at all times Wink
Reply
#9
really but i was hoping it should be around 50 and that 35 fps is no different
than those 3ghz less cpu, seems like my overclocking was not worth it. sigh*
Reply
#10
Hm, that's just a normal fight scene. Looks like your GPU is too slow for this?
You can test this: Set your GSdx internal resolution to 256*256 and see if that speeds up the battles.
Reply




Users browsing this thread: 1 Guest(s)