Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 FES - Sprite glitch
I'm have a minor problem (more of an annoyance than anything) with P3:FES. In conversations, whenever a character's sprite blinks, a line appears about 1/2 inch above their eyes and their face appears to "jump".

I'm using the latest build (0.9.6) with GSdx 890 (MSVC 15.00, SSE2) 0.1.14 as my plugin, set with Direct3D10(Hardware), {Setting it to software corrects the sprite issue, but it drastically lowers the 3D quality.} interlacing set to none,and texture filtering checked.

I also have a Nvidia GeForce 9800 GT.

I'd post a screen of it , but its kind of hard to capture it.

EDIT: I guess I should also mention I have that "flickering rainbow" floor effect too. I know there's a fix for it somewhere/how...

Sponsored links

Yeah you can use the latest 1888 beta to get rid of the flickering rainbow floor, by enabling microvu0 and microVU1 in CPU config. The shaking you mention should go away by pressing the F5 key as many times as it takes (it cycles through GSdx's interlace options)

The line could be caused by a custom internal resolution and can't be avoided unless you check 'Native' in GSdx. Although then the image quality will be quite lower since PCSX2 will render everything at the native PS2 resolution which is usually around 640x480 or lower
[Image: newsig.jpg]
Thank you for your help, Bositman. I think it a problem with the sprites not overlaying on top of each other.

I also ran into another problem. I can't seem to select what skill I want to delete when my persona learns more then 8 skills. I can't move the cursor at all and I'm forced to delete the first skill, whether I like it or not.
To move the cursor Use the arrows D-Pad instead of the analog stick, also you can get rid of the line on the characters if you uncheck texture filtering or half check it...the characters sprites will look a little worse but i find it not as nearly annoying as the blinking line.
This was an error on my part but I forgot to mention it [the cursor] doesn't move whether i use the D-pad OR the analog stick.

I also switched to the ZeroGS 0.97.1 plugin. Since then, the rainbow floor is gone, along with the line through the character's sprites heads. However, the sprites still don't overlay each oter correctly, but its alot less noticeable.
Playing my 1st game with pcsx2, and have this minor dialog sprite problem.
I get it there is no way to avoid it other than turning to native resolution? 3d looks really ugly with it...
Try disabling or greying the "texture filtering" option.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Doesn't help.
GSdx settings?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Tested diifferent resolutions and scaling, all interlacing modes, dx9/dx11.
No hacks, tried the offset hack.

Users browsing this thread: 1 Guest(s)