Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 FES White Shadows Issue
#1
Hey I've been playing Persona 3 FES and the game runs fine with 60 fps except for a few fights that were boss fights which I just ignored and got over with that ASAP. Now that I'm in the final five to ten hours of the game or so I've noticed that the slowdown seems to be attributed to the fact that the shadows are rendered in a shade of white. When the camera pans off them (or I just beat them) the game will immeadiatly go back to full speed. Normally I would just ignore it but 90% of these enemy's are this color. Any suggestions? I've tried speedhacks and the persona bug fix but this only gets me from about 5-10 fps to 20-25 if im lucky. If i'm in the fight too long it dips down to below 1 fps and won't return untill ive closed the screen and resume it about 2 min later.

System specs
intel core 2 quad 2.66 ghz
6 gb ddr2 ram
nvidia 9500 gs 512 mb
running pcsx2 0.9.8
Reply

Sponsored links

#2
Are you using PCSX2 v0.9.8? Your graphics card is what is causing the slowdowns, try checking 'Native' in GSdx
[Image: newsig.jpg]
Reply
#3
Yeah I'm running 0.9.8. Tried hitting the native but no change. "Native" in the plugin sections correct?
Reply
#4
Native is in the options GSdx gives you when configuring it
[Image: newsig.jpg]
Reply
#5
Right for Native ps2 resolution. Yeah i've tried it and it doesnt make a difference. Didn't think it would be a graphics card issue for just a single color. Anything else? Other than the obvious 'upgrade your graphics card' option Laugh
Reply
#6
Oh and quick edit, I should mension that by "shadow" I mean enemies. The slowdowns only happens in fights, Shadows are the enemies in the game not shadows cast by like objects and stuff. Just wanted to clarify.
Reply
#7
Yeah it's a known 'bug' in P3, some golden enemies use some effect that makes GSdx crawl for some reason (thus needing much more power off your GPU compared to the rest of the scenes on the game). Just to make sure, try pressing F9 (switching to software renderer) and see how the speed does at that moment. Oh before doing that, configure GSdx setting it to software renderer and setting SW render threads to 3, then back at hardware.
[Image: newsig.jpg]
Reply
#8
You sir are a genius! I almost got so frustrated with the slowdown I thought about not finishing the game. With speedhacks and F9 im back up to nearly full speed. Thank you very much. One last question though, should I leave it on or turn if off after the fight?
Reply
#9
Well after the fight, you can set it back to hardware if your graphics card can handle anything higher than native resolution. 2X scaling for example, looks far better Wink
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)