Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 FES issues
#1
I'm not sure if this is the right place to put this since I'm new but I'll ask anyways. I'm having issues with playing persona 3 fes. Every time I load my save file from the game the screen goes black. This does not occur on the main menu when loading the game or the in game menu when pressing triangle, nor when my character is in his room and has the choice to study or sleep. This problem did not happen until I updated windows 8 to 8.1. I have tried fixing it by tweaking pcsx2 but nothing worked I have even download the new pcsx2 but that did nothing. I'm not sure how to fix this problem so if anyone knows how I can fix this problem I would appreciate it.
Reply

Sponsored links

#2
(02-19-2014, 01:52 PM)Yutaka Wrote: I'm not sure if this is the right place to put this since I'm new but I'll ask anyways. I'm having issues with playing persona 3 fes. Every time I load my save file from the game the screen goes black. This does not occur on the main menu when loading the game or the in game menu when pressing triangle, nor when my character is in his room and has the choice to study or sleep. This problem did not happen until I updated windows 8 to 8.1. I have tried fixing it by tweaking pcsx2 but nothing worked I have even download the new pcsx2 but that did nothing. I'm not sure how to fix this problem so if anyone knows how I can fix this problem I would appreciate it.

Are you using speedhacks?

This shouldn't be necessary but try pressing F9 after it goes black.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#3
(02-19-2014, 02:03 PM)Donovan24 Wrote: Are you using speedhacks?

This shouldn't be necessary but try pressing F9 after it goes black.

Thanks that worked, what did that do? Also the speedhacks are whatever they are as default.
Reply
#4
(02-19-2014, 02:08 PM)Yutaka Wrote: Thanks that worked, what did that do? Also the speedhacks are whatever they are as default.

That put the game in software mode. You were running in hardware mode. Software mode is much more accurate but looks worse.

From what I've seen, software mode shouldn't be necessary for this game though.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#5
(02-19-2014, 02:12 PM)Donovan24 Wrote: That put the game in software mode. You were running in hardware mode. Software mode is much more accurate but looks worse.

From what I've seen, software mode shouldn't be necessary for this game though.

Accurate in what sense?
Reply
#6
(02-19-2014, 02:17 PM)Yutaka Wrote: Accurate in what sense?

Emulation wise?

Software mode most closely resembles an actual ps2 thus fixing a lot of glitches/bugs
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#7
Try installing the latest version of your GPU drivers, the 8.1 update might have screwed something up by the looks of it...
Reply
#8
(02-19-2014, 04:04 PM)pablocrossa Wrote: Try installing the latest version of your GPU drivers, the 8.1 update might have screwed something up by the looks of it...

How would I do that?
Reply
#9
(02-21-2014, 09:30 PM)Yutaka Wrote: How would I do that?

What GPU do you have?
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#10
[attachment=49180]
(02-21-2014, 09:40 PM)Donovan24 Wrote: What GPU do you have?

Intel® HD Graphics Family
Reply




Users browsing this thread: 1 Guest(s)