Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3 FES random slowdown issue.
#1
Sad 
The problem:
After starting up a new game (after the main menu) the game randomly goes into slowmotion, running at about 30 fps, then after 20-30 seconds of so it restores back to the full 60 fps again like it doesn't have a problem with it at all. Even in-game while standing stationary doing nothing every 20 seconds the emulator slows down back to 30 fps like it's having a hard time. The slowdown also effects the sound.

It doesn't seem to matter what state the game is in, the slowdowns happen wether I am doing something or not, and it usually takes around 30 seconds before the slowmotion suddenly ends and I can run the game fine on 60 fps again w/o any trouble.

What I've tried:
I've tried playing with a lot of speedhack options and the manual game fix.
I've tried multiple versions of pcsx2 (0.9.6, 1.0.0 and 1.2.1). I've noticed the game runs the smoothest on 1.0.0 but the slowdown issues seem to be entirely unrelated as they happen on all 3 versions.
I've tried changing the video plugin settings (GS), changing the renderer from hardware to software, disabling extras that might slow the emulator down a bit. but nothing seems to make a dent. It either makes the overall performance better or worse, but nothing fixed/alters the random slowdown/drop to 30fps.

My specs:
Win 8.1 64x
4 GB DDR3 Ram
200 GB SSD
ATI Mobility radeon HD 5730 1GB
i7 Q720 @ 1.60 GHz

My current settings:
EE/IOP (nothing changed)
EmotionEngine: Recompiler (enable EE Cashe disabled)
IOP: Recompiler
Round Mode: Chop/Zero
Clamping Mode: Normal

VUs (nothing changed)
VU0 & VU1: MicroVU Recompiler
Round Mode: Chop/Zero
Clamping Mode: Normal

GS (not sure if changed)
[ ]Disable Framelimiting
[ ]Use Synchronized MTGS
[ ]Disable all GS output
Frame Skipping: Disabled [default]

GS Window
Aspect Ration: Widescreen
Custom Window Size: 1600 x 900
Zoom: 100.0
[ ] Disable window resize border
[ ] Always hide mouse cursor
[x] Hide window when paused
[ ] Default to fulscreen mode on open
[x] Double-click toggles fullscreen mode
[ ] Wait for Vsync on refresh
[ ] Dynamically toggle Vsync depending on frame rate

Speedhacks
[x] Enable speedhacks
EE Cyclerate: 1
VU Cycle Stealing: 0
[x] Enable INTC Spin Detection
[x] Enable Wait Loop Detection
[ ] Enable fast CDVD
[x] mVU Flag Hack
[ ] MTVU

Game Fixes
[ ]Enable manual game fixes ( I tried enabling this with the "VU Clip Flag Hack" but it didn't fix anything)


That's it, if you need any more info feel free to ask, I wanna cooperate in fixing this as much as I can. Thanks in advance Smile
Reply

Sponsored links

#2
Your cpu might be your issue here. Mainly recommended would be to have atleast a quad core running on 3.0 Ghz. I understand that most people want to play it on their laptop, since you can play it anywhere you want, but still. Also if it slows down make atleast sure if it's a quad core that you turn on MTVU hack. Also try to lower the custom resolution, atleast try to see how the game runs on native and then step up to 2x or 3x. P3FES can be a heavy game with some area's.
Reply
#3
Thanks for the fast reply.

Enabling the multicore setting like you said did make the slow downs WAY less frequent. to the point where it's hardly annoying at all. That's what I've noticed on a first try, so that's amazing. I was already playing on native resolution and I think I'll keep it like that for now.

And indeed, I am playing on my laptop, it's the only system I own. It's pretty alright when it comes to gaming, but when I start emulating it's like it's not using it's full potential.

Anyway thanks for the help! If there is any other way of speeding up the emulation a tad I'd still like to know it. But the main issue has been solved Wink
Reply
#4
Did you see if it makes a difference by starting the game on native instead of custom resolution and then go up from there? Your CPU and GPU are on the slow side, even though I played this game awhile back on my 6000+ with a 5770 and only had slowdowns with white enemies and gold hands.
Reply
#5
I notice an incredible quality increase with no additional slowdown Smile thanks for the tip!
Reply
#6
np that's why this forum is here for Smile Also make sure that you use the latest version of PCSX2 in this case a SVN, which have always the latest version of every plugin.

http://buildbot.orphis.net/pcsx2/
Reply




Users browsing this thread: 1 Guest(s)