Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3, Game CG Aliasing
#1
Exclamation 
I'm wondering how can I remove the aliasing of game CG in Persona 3 FES,
I already tried switching to different resolutions but it came out to be the same.
I also enabled the Edge Aliasing (AA1).

Are there any other way to improve those game CG?
The field rendering seems to be fine, but I want those CG to look as best as they can.
The screenshot provided below are examples, I can give more screenshot if necessary.
Any help would be much appreciated.


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
It's my understanding that Edge AA only applies to software mode. Have you tried running in hardware mode? I know that it has some visual glitches here and there when you do that but at least that way you can bump up the resolution and make the game look REALLY good, and you can apply A LOT more AA to it too. What are you specs though? I see you're running on a laptop and based on your screen resolution, I'm guessing it's an ultrabook so maybe you won't be able to upres the game too much.
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#3
Windows 8.1 x64
Intel Core i7 4510U @ 2.00 GHz (4CPUs), ~ 2.6GHz
I can boost it up o 3.00GHz
8 GB RAM
Nvidia GeForce 840M

Using Software improves the game CG but it tends to lessen the quality of field rendering.
As for the Hardware, a good field rendering but CG's are aliased.
Is there any other way where I can enable hardware and software at the same time? lol


P.S.

Newbie here


Attached Files Thumbnail(s)
       
Reply
#4
I'm not exactly sure what you're talking about with the CG being aliased in hardware mode..if anything it's more aliased in software mode because of the lower resolution. Software mode can only run at the PS2's native resolution so it's pretty limiting as far as visual quality. Could you point out to me what you're seeing in the software mode screenshot that looks more appealing to you than it does in the hardware mode screenshot?

And no, you can't enable software and hardware modes at the same time.
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#5
Hardware mode - Good field rendering, but the CG's are messed up. Aliased.
Software mode - Low quality field, and CG's are fine.

I'm guessing there's no way of fixing this.
I'm still trying to manipulate the plug in.


EDIT:

I think I found the solution?
I tried enabling 8-bit texture and Anisotropic filtering.
It worked out I suppose.
Reply
#6
How are the CGs fine on software mode? They're so low-res O_O Maybe you don't see as much aliasing in software mode because everything is so blurry lol

Yeah I was going to suggest Anisotropic filtering. Allowing 8-bit textures don't actually make a difference in quality though, that's just for gaining performance in certain games. Did you turn on AA as well? It's under HW Hacks.
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#7
The FMVs look better in software because it's at native resolution(which they were designed to be played at). To play the game in hardware, and auto switch to software for FMV do this:

Go to config->Emulation settings, game fixes tab. Enable manual game fixes. Check "Switch to GSdx software rendering when an FMV plays."
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
Oh he meant FMVs? Now it makes more sense!
[Image: pNm13X9.gif]
Windows 10 Pro x64 | Intel Core i7-4790K @ 4.00 GHz | PowerColor R9 290X 4GB | G.SKILL 16GB (4x4GB) DDR3 1600 RAM | Samsung 850 EVO 250 GB SSD | Seagate ST3000DM001 3TB HDD

CPU Intensive Games
GPU Intensive Games
Games that don't need a strong CPU
Reply
#9
Maybe he did? I took it to mean he did, but now I think he may have meant the character portraits.

To make those looks as best as possible, config->video->plugin settings. Find texture filtering. Make it a full check box, not a shaded box(shaded box only filters 3d, not 2d)
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
I finally got the settings that I want.
Thank you guys,
+rep to both of you.

By the way,
I'm talking about the character portraits.
Umm, I don't know why others call it CG.
lol

Anyway, Thanks again.


Attached Files Thumbnail(s)
       
Reply




Users browsing this thread: 1 Guest(s)