Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 3, very slow despite 60FPS
#1
As soon as the auditorium scene hits, everything goes downhill. It's like I'm trying to play Crysis on a single core Windows 95 with no RAM. Once every 10 seconds there will be a frame change.

However, the FPS counter is still showing 60FPS, and the sound is doing just fine.

There any particular reason for this?

AMD Athlon 6400+ 3.2Ghz Dual Core
4GB Ram
8800GTX Nvidia
Vista 32


I've tried using DX9, and that didn't help.

I'm also looking at my task manager...it says PCSX2 is only using up 64% CPU.
Reply

Sponsored links

#2
What plugins and settings you are using? Make sure you play that game in Iso, not direct playing to your dvdrom.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Reply
#3
It's possible that speedhacks or VU Frameskip causes that. Disable speedhacks and VU Frameskip if you have these on.
Reply
#4
Sorry it took me so long to respond. I figured it out right before heading to sleep and I completely forgot about the topic I made.

Turning off the frame skip feature fixed it...but...it slows down to around 40FPS when they're having their little group discussions. Is there anyway for me to turn on the frame skip feature while still maintaining STABLE gameplay?

EDIT: Setting oth clamp settings to NONE seemed to help a bit.
Reply
#5
I'm guessing you're using the GSdx plugin, I had this problem too with Persona 3 so I switched to ZeroGS.
Reply
#6
(04-09-2009, 02:50 AM)Typheus Wrote: Sorry it took me so long to respond. I figured it out right before heading to sleep and I completely forgot about the topic I made.

Turning off the frame skip feature fixed it...but...it slows down to around 40FPS when they're having their little group discussions. Is there anyway for me to turn on the frame skip feature while still maintaining STABLE gameplay?

EDIT: Setting oth clamp settings to NONE seemed to help a bit.

Well, from what you describe it seems that your processor just isn't enough for the job. Try checking different speedhacks and seeing if they'd help.
Reply
#7
It don't matter, I've got it running 60FPS at all times, save for when they're in an auditorium.
Reply
#8
(04-09-2009, 04:59 AM)Typheus Wrote: It don't matter, I've got it running 60FPS at all times, save for when they're in an auditorium.

Well, unlucky you then.
Reply
#9
Cain, you're right. You've invested more money into your PC and it's much better than mine. So much better in fact, that it can run Persona 3 at any scene at 60FPS.
Reply
#10
(04-09-2009, 06:15 AM)Typheus Wrote: Cain, you're right. You've invested more money into your PC and it's much better than mine. So much better in fact, that it can run Persona 3 at any scene at 60FPS.

Whoa, sarcasm. Not very good at it, are you? I've never seen it in fact and simpy using common sense.
Reply




Users browsing this thread: 1 Guest(s)