Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 4 Foggy area slowdown.
Hey, guys. I've been looking for a work-around on the foggy areas of the game( such as the MC's dream dungeon or Sauna dungeon). I'm not sure why fog is slowing down the game. The game runs mostly 60fps in other areas, and in the areas with the fog effect it drops to 35-40 or so.
I'm using PCSX2 beta.r1888.

Sponsored links

This thread will help you out:
Definitely not a bug, moved.

Show us your system specs and pcsx2 settings so we can help better.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
strange, i finished persona 4 two times on PCSX2 and i never had any slowdowns in foggy days or areas. Both on dx9 and dx10 hardware mode.
Check my profile for hardware/software and games i played on PCSX2.
Here's my PCSX2 beta settings. Oh and sorry for posting in the wrong section :-/
[Image: settingsp.jpg]
[Image: sphacks.jpg]
GSdx with DirectX 10 hardware.
Advanced: Set on Default.
CPU:everything marked with Limited fps.

System specs:
AMD Athlon 64 X2 Dual-core porcessor 6000+ 2,99GHz
GeForce 8600GT

Also, here's the area with the fog effect.
[Image: p4fog.jpg]
Other places that contain fog(midnight channel, sauna) also have the same slowdowns)
i have played persona 4 my self and i dont get slow downs in the fog it must be your settings or your computer is not good enough just
Could you please tell us, how you configured GSDX. I mean, which resolution you choose? Because if I remember right, exactly these areas with fog seemed to be good to emulate and my processor calmed down a bit. But perhaps is this something for the GPU to work.
Rejoice, they say. Color is back.
Just tried changing the resolution. Didn't help.

GSdx settings:
Resolution:1024x768 75Hz
Renderer: Direct3D 10 (hardware)
Aspect Ratio: 4:3
D3D Internal res.: 1024x1024 ("native" not ticked)
Texture Filtering ticked.
Hmm, this seems odd to me. I played this area a day or so ago and there my processor had a lower activity than in other ones (I always play with task manager). Perhaps you could try to set the "Clamp Mode" in the advanced settings to "None". I never had this on while playing it, perhaps it'll help.

Some other ideas: Are you playing with MicroVU? Because if yes, look if you have unticked the gamefix for Persona. If no, deactivate the speedhack for it. Perhaps could this be the problem. You can turn off MicroVU for Persona 4 after all. It works just fine with SuperVU and has about 7 fps more for me. But then, tick the gamefix for the textures.
Rejoice, they say. Color is back.
Did what you offered, but it only increased my fps by 1. I believe that this "fog" is a sprite. not the typical fog that you would see in the distance. Thanks for the help, dude.

Users browsing this thread: 1 Guest(s)