Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 4 audio skipping?
#1
Well I got Persona 4 working the other day, and everything seems to run fine until I get into areas like the class room etc.

The framerate stays at a crisp 60 FPS, but I get a lot of audio skipping every couple seconds which is extremely annoying.

For the graphics plugin I use SSSE3 0.1.15, I have the screen size set to 1024x768, D3D Internal Res set at Native, with all the extras turned off bar Logarithmic Z and running it windowed.

For sound I have interpolation at 0 and 1-XAudio 2 for the module and I've also disabled effects processing and time-stretching. This eliminated audio skips in most areas bar such areas I mentioned above.

I've enabled pretty much all the speed hacks, and I've tried every possible combination. When I set VU Cycle Stealing to medium it eliminates audio skips and while the game stays at 60 FPS, everything seems to move in slow motion. When I set it at low I get regular game speeds but the audio skips start again.

My PC specs are:
Vista 32 Bit
Core 2 Duo @ 2.66 GHZ
ATI Radeon HD 2400 Pro
4 GB RAM

Even at max overclock I still get the audio skips, do you guys have any suggestions for me?
Reply

Sponsored links

#2
Quote:The framerate stays at a crisp 60 FPS, but I get a lot of audio skipping
Hmm let's see, the description of speed hacks are talking about breaking games and some in particular have warnings about messing up the audio.
I wonder if that has anything to do with this:
Quote:I've enabled pretty much all the speed hacks

Enable hacks, games get broken. I don't see why NO ONE seems to realize this simple, straightforward fact. Yes you get speedups and that comes with a price.
If you can't get full speed without speed hacks, audio will still be slow since it will try synchronizing with the video which is also slow. Which is your case since classroom scenes and crowded places are the most demanding areas of the game since there are lots of stuff to render.
[Image: newsig.jpg]
Reply
#3
(02-22-2010, 12:06 AM)Bositman Wrote:
Quote:The framerate stays at a crisp 60 FPS, but I get a lot of audio skipping
Hmm let's see, the description of speed hacks are talking about breaking games and some in particular have warnings about messing up the audio.
I wonder if that has anything to do with this:
Quote:I've enabled pretty much all the speed hacks

Enable hacks, games get broken. I don't see why NO ONE seems to realize this simple, straightforward fact. Yes you get speedups and that comes with a price.
If you can't get full speed without speed hacks, audio will still be slow since it will try synchronizing with the video which is also slow. Which is your case since classroom scenes and crowded places are the most demanding areas of the game since there are lots of stuff to render.
Yes I do realize that, you'll also see that I wrote I've tried all speed hacks on and off and I still get audio skipping.

The only game altering affect I have from the speed hacks is the VU Cycle stealing at medium causing slow mo game play.
Reply
#4
thats is beacuse when you use speedhacks you get false 60 fps,so the sounds get choppy,and when you disable the speedhacks then you will get the same sound problem.So the main thing is that you are not getting full speed in this game truly
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#5
Well I disabled all speed hacks again and I get 50FPS in busy scenes which is still a good frame rate, but the audio skipping is still there.
Reply
#6
With SPU2-X, time stretching enabled and interpolation at linear skipping won't happen. It will slow down, but not skip.
[Image: newsig.jpg]
Reply
#7
(02-22-2010, 01:06 AM)Bositman Wrote: With SPU2-X, time stretching enabled and interpolation at linear skipping won't happen. It will slow down, but not skip.
Ah, I get very little slowdown with this. Thank you.
Reply
#8
Curious: Did you disable timestretching because it said something like "speedup" or so?
It really isn't an option, we should remove the checkbox for it..
Reply
#9
(02-22-2010, 01:52 AM)rama Wrote: Curious: Did you disable timestretching because it said something like "speedup" or so?
It really isn't an option, we should remove the checkbox for it..
Yeah, it said that it gives a small speed up and helps eliminate audio skips.
Reply
#10
Ehr no... it says time-stretching helps eliminate audio skips. But the option says "Disable time-stretching" so you were getting the opposite effect of what you wanted by ticking it... maybe not removing the option itself but changing the description and name instead xD
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)