Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Persona 4 fps drops (don't know much about the emulator)
#1
Hello everyone, well my problem is that I have been playing Persona 4 for a while now and have noticed a few fps drops here and there like for example when there is a lot of fog. I'm sorry for the ignorance but I don't really know much about the emulator and I think my machine is good enough to run it at full speed (intel core i5 3570k, nvidia gtx 550ti), I mainly use Dolphin where I can run games like monster hunter tri and xenoblade chronicles without any problem. If anyone could help me maybe configure some settings in the emulator to make the game run at a better speed it would be awesome Smile thanks everyone in advance
Reply

Sponsored links

#2
Try 2xnative resolution, goto sound plugin and tick disable effact.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#3
Start by posting your computer specifications. If you don't know how, get Speccy and copy the contents of its main tab.
Reply
#4
Op have i5 3570k and gtx550ti i think its enough for this slowdown case.
:-)
:-P
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#5
My "normal" framelimit sets it at 54fps, but when i toggle F4 it goes all the way to like 150fps, how can i make it stay at 60?
Reply
#6
Persona 4 can run mostly smooth on an old Dual Core @ 3Ghz. So I doubt a Core i5 should be be having problems.

One thing to try would be enabling MTVU. It can make some games slower, but it tends to help framerate drops. Also, which version of PCSX2 is OP running?
Reply
#7
(10-12-2013, 07:08 PM)Linker357 Wrote: My "normal" framelimit sets it at 54fps, but when i toggle F4 it goes all the way to like 150fps, how can i make it stay at 60?

press again f4
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#8
I think he's asking how to keep his FPS at 60, since it sits at 54. F4 isn't going to help there.
Reply
#9
wow dude your pc specs is more than enough to play that game at full speed at x3native resolution ,just use the basic speed hacks and settings and try to play the game again
Reply
#10
Okay yeah I managed to figure it out Smile some setting was limiting my fps don't know why but it's running smooth and dandy now, thanks everyone for their responses Laugh
Reply




Users browsing this thread: 1 Guest(s)