Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pixellated UI in Champions of Norrath
#1
Is there any fix to the pixelation in the UI while playing Champions of Norrath at 2x Native resolution or more? Screenshot below showing the comparison between the game engine and the pixelated menus.


   
Reply

Sponsored links

#2
try turning texture filtering on.
but keep in mind resolution enhancements are mostly for 3D Graphics.

2D elements (like menus) will look pixelated anyways. texture filtering may softem them a bit though.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(06-08-2017, 05:02 PM)jesalvein Wrote: try turning texture filtering on.
but keep in mind resolution enhancements are mostly for 3D Graphics.

2D elements (like menus) will look pixelated anyways. texture filtering may softem them a bit though.

Hi! Thanks for the help! I'd love to turn it on but I don't seem to have the option or, if I do, it's not doing anything. Screenshot shown below.


Attached Files Thumbnail(s)
   
Reply
#4
Texture Filtering is under "Hardware Mode Settings", set it to Bilinear (forced) to reduce menu pixelation
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#5
(06-08-2017, 07:17 PM)Dreadmoth Wrote: Set Texture Filtering to Bilinear (forced) to reduce menu pixelation

Set Round Sprite hack to Full to reduce gaps and lines in menus (may slightly cut off some icons)

If using OpenGL renderer, set Blending Unit Accuracy to None (fastest) to improve colour quality and reduce colour banding


Thanks for the reply! I tried out this solution but am having no luck, couldn't notice a difference. Will I just have to deal with having super pixelated menus or is there am I doing something wrong? T
Reply
#6
Sorry - I was late posting that, I edited the post.

In PCSX2 1.4.0 the Round Sprite hack effectively disables texture filtering on the menus in Champions of Norrath - turning it off should allow texture filtering to smooth them out. Perhaps also try setting Interlacing (F5) to "Blend bff", maybe the Auto setting is using the wrong mode.

If that still doesn't work, you might want to try updating the the latest PCSX2 development build from here - which seems to allow the Round Sprite hack and texture filtering to work together. The result should look like this (4x Native, widescreen hacks disabled)
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#7
(06-08-2017, 07:46 PM)Dreadmoth Wrote: Sorry - I was late posting that, I edited the post.

In PCSX2 1.4.0 the Round Sprite hack effectively disables texture filtering on the menus in Champions of Norrath - turning it off should allow texture filtering to smooth them out. Perhaps also try setting Interlacing (F5) to "Blend bff", maybe the Auto setting is using the wrong mode.

If that still doesn't work, you might want to try updating the the latest PCSX2 development build from here - which seems to allow the Round Sprite hack and texture filtering to work together. The result should look like this (4x Native, widescreen hacks disabled)

So, the issue has been fixed! Turns out that turning off Round Sprite completely actually fixed it as the forced texture filtering suddenly worked. Picture below. There's only some slight black lines around some of the textures but it's such a non issue compared to what it looked like before that it doesn't really matter. Thanks so much both of you!


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)