Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Please help, Game goes from above 60 fps to start to below 30
#1
Before I start here are my system specs

Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit
Physical RAM = 16383 MB (8 gigs)
CPU name = AMD Phenom™ II X6 1090T Processor
Video Card = GeForce GTX 550 Ti 1024 MB GDDR5

I built the computer myself so I know it is a good machine. I have "Hot Shots Golf 3 and Hot Shots Golf FORE. When I start the emulation it runs fine above 60 fps then i can hear audio slowing and some video slowing in the beginning. Then it gets to the menu and runs over 60 fps, once i start the game it drops to 30 fps or lower. I tried a fix by shutting off the console it rose to 45 fps then went straight back down. After I hit the ball right before it lands the fps starts going up. but then will slow right back down.

I have it set at:

Direct3D11 (Software)
Blend tff

and here is what the console says, from the time I open the emulator to the time I have it at right now, playing the game.

PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit
Physical RAM = 16383 MB
CPU name = AMD Phenom™ II X6 1090T Processor
Vendor/Model = AuthenticAMD (stepping 00)
CPU speed = 3.199 ghz (6 logical threads)
x86PType = Standard OEM
x86Flags = 178bfbff 00802009
x86EFlags = efd3fbff

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3
MMX2 .. 3DNOW .. 3DNOW2.. SSE4a

Reserving memory for recompilers...

Loading plugins...
Binding GS : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse2-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GTX 550 Ti (8.17.12.8562)
Binding PAD : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : F:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9082 games on record (loaded in 210ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.1.7601 (Service Pack 1 1.0)
NVIDIA GeForce GTX 550 Ti (8.17.12.8562)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: F:\Program Files (x86)\PCSX2 0.9.8\Games\Hot Shots Golf FORE\hsgf_ntscU.ISO
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1423856 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Ricky D\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Ricky D\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v01.60(07/02/2002) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
GIFTAG warning, size exceeded VU memory size 400
GIFTAG warning, size exceeded VU memory size 400
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.01;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.01;1) Game CRC = 0xD7F42600, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.01;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.01;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.01;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS
Suspending single plugin: GS
Saving GS
Closing GS
Recovering single plugin: GS
Opening GS
Loading GS


Sorry for the long post, I just wanted to get every bit of information I could out there to see if anyone at all can help. I've been working at it by myself for about 3 days now and no luck with anything. So please if you know whats going on, please please help Smile Thank you!

Just to update its running at 23.5 fps right now. My emulation. Not sure why it doesnt show that on the console
Reply

Sponsored links

#2
Try making an ISO image of your game using imgburn (click Create image file from disc). Then to run it with PCSX2: CDVD->Choose ISO, then ISO selector->Browse, find your ISO and System->Boot CD/DVD (fast)
[Image: newsig.jpg]
Reply
#3
(01-14-2012, 08:55 PM)Bositman Wrote: Try making an ISO image of your game using imgburn (click Create image file from disc). Then to run it with PCSX2: CDVD->Choose ISO, then ISO selector->Browse, find your ISO and System->Boot CD/DVD (fast)

I will try that, before I was using UltraISO
Reply
#4
Oh you were already using an ISO..hmm..what do the EE and GS% display on the top of the GSdx window when you get the slowdowns?
[Image: newsig.jpg]
Reply
#5
(01-14-2012, 09:00 PM)Bositman Wrote: Oh you were already using an ISO..hmm..what do the EE and GS% display on the top of the GSdx window when you get the slowdowns?

When I start the emulation

EE is 84-92%
GS is 50-65%

After its running the game

EE is 66%
GS is 99-100%
now the ee is jumping all over the place. going as high as 100% as low was 65%
Reply
#6
OK try configuring GSdx and checking 'native'. If that still doesn't work, set GSdx to DX11 software renderer and set SW render threads to 3
[Image: newsig.jpg]
Reply
#7
It is running much faster now then when on Software. The hardware makes everything grainy. But I guess to have it run correctly gotta sacrifice something huh. lol Thanks for your help.
Reply
#8
he has a six core cpu, so he can set it to four even with no hyperthreading.
Reply
#9
that eliminated the graininess. Thank you. very small frame loss but bearable.
Reply




Users browsing this thread: 1 Guest(s)