Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Poor performance modern hardware
#1
So I've got a R9 270 and i5 4440, but many games on the PCX2 emulator have poor performance. Right now I'm playing the simpsons road rage, it plays alright when I have hardware rendering enabled but most of the world renders as black, but then when I use software rendering (DX9 & 11) I often get choppy frames and audio. Is there a fix for this? Thanks.
Reply

Sponsored links

#2
software rendering is demanding.
settings 3 extra rendering thread, may help, though.
did you try using OGL hardware renderer ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Yeah thought software rendering was more demanding, Don't really know what you mean by settings 3 extra rendering thread, and OGL was worse performance wise. I have fixed it for the most part tho by updating the emulator (from 1.2 to 1.4) and that seems to work much better thanks.
Reply
#4
gsdx plugin configuration -> at the bottom you find extra rendering threads.
Reply
#5
if your using AMD stick to DX11, till AMD fixes there OpenGL implantation, OpenGL is only recommended if your using Nvidia cards
Reply
#6
(04-14-2016, 07:10 PM)tsunami2311 Wrote: if your using AMD stick to DX11, till AMD fixes there OpenGL implantation, OpenGL is only recommended if your using Nvidia cards
Numerous games do work fine in OpenGL with AMD GPU's, and as OpenGL is the most accurate renderer, you shouldn't tell people to ignore it.
Reply
#7
(04-14-2016, 08:04 PM)FlatOut Wrote: Numerous games do work fine in OpenGL with AMD GPU's, and as OpenGL is the most accurate renderer, you shouldn't tell people to ignore it.

Most accurate maybe, but for AMD users, the performance is still bad even in the most recent versions. At least until they decide to fix the broken drivers. Maybe if you have a beast AMD card it will work for 'numerous' games, but I have yet to see a game in OGL that runs at constant full speed for me whereas the same game does run at full speed constantly using DX11. (That's with an R9-280)
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#8
(04-14-2016, 08:15 PM)Ryudo Wrote: Most accurate maybe, but for AMD users, the performance is still bad even in the most recent versions. At least until they decide to fix the broken drivers. Maybe if you have a beast AMD card it will work for 'numerous' games, but I have yet to see a game in OGL that runs at constant full speed for me whereas the same game does run at full speed constantly using DX11. (That's with an R9-280)
You must have a really unlucky game collection, cause my AMD GPU is inferior to yours and I'd say about 50% of the games I've tried run full speed at at least 3x native with OpenGL.
Reply




Users browsing this thread: 1 Guest(s)