Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem Booting pcsx2.app
#1
Hello all,

I am new to pcsx2 mac and need some help getting the thing to run. I have read all the relevant threads i.e. "How to Run" and the guides to get the program up and running.

I am running Snow Leopard (10.6.8) and just trying to get pcsx2 to run. I have installed XQuarts and the NVidia framework as required by the program. Also, I have installed the Snow Leopard pcsx2 package. When I try to launch it, however, nothing happens.

I tried running pcsx2.app from an XQuartz terminal directly and I received the following error message:

LSOpenURLsWithRole() failed with error -10810 for the file /Applications/pcsx2.app.

Thinking this message had something to do with the permissions that were set up on the app, I changed the access on it to read/write. Still, no good. If somebody has gone through similar problems before and resolved them, please help me. I will provide more information if needed.
Reply

Sponsored links

#2
Did you try just opening xquartz from your utilities folder and then double click pcsx2.app? Some people have gotten it to work this way. If this works for you, then you don't need to keep doing this, it should do it automatically from then.
13" MacBook Pro (March 2011)
Display: 1280x800
CPU: Intel Core i5 2.3 GHz w/ 2.9 GHz Turbo Boost
Memory: 4 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 384 MB
Software: Mac OS X Lion 10.7.3

Reply
#3
Yes, I did try that and it still refused to open. It's very strange.
Reply
#4
Ehh, I was able to run the program by doing a very hacksy thing. I had to go directly into the package contents and run the pcsx2 executable within the folder /Contents/Resources/pcsx2. It may just be that my permissions on that folder are a bit messed up. If I figure out what the problem was, I will post here again. At the very least, it seems like some progress has been made on this front.
Reply
#5
(09-30-2011, 05:31 PM)elminster55 Wrote: Ehh, I was able to run the program by doing a very hacksy thing. I had to go directly into the package contents and run the pcsx2 executable within the folder /Contents/Resources/pcsx2. It may just be that my permissions on that folder are a bit messed up. If I figure out what the problem was, I will post here again. At the very least, it seems like some progress has been made on this front.
Can you explain a little more in depth how you solved this problem, I got the folder /Contents/Resources/pcsx2 in terminal then tried "open pcsx2" but it didn't do anything. Any help would be greatly appreciated, thanks
Reply
#6
I'm having the same problem. Running 10.6.8 on a 2.2 Ghz MPB (from 2008).

Went based on the guide, installed the CG stuff, xquartz and pcsx2, and even after logging out and restarting, still not getting anything. I followed some advice in there too and deleted pcsx2 and re-installed. Nothing.

I open Xquartz and double click on pscx2.app and the icon does that transparent coming towards you thing, acknowledging that I did in fact try to open it, but nothing happens after that.

I also tried to open it using the old method that someone typed up in like 2009, typing in "cd /Applications/pcsx2/bin" into the xquartz terminal and apparently the folder for pcsx2 isn't there. Oopsie...

I feel like I should at least be getting a troll-face icon asking me "Problem?" after all this, but I don't even get the satisfaction of that.
Reply
#7
your permissions may be broken.
if you select the folder which contains it all, right click and select get info, and at the bottom there is a spot with permissions, give yourself full read/write privileges AND then select the little gear icon below the permissions and select apply to enclosed items which will change the permissions of every file and folder inside that folder.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#8
You can also try to use BatChmod 2 if the previous mentioned stuff doesnt work.

EDIT:
Fixed typos
"Eventually you too will hear it, The Last Melody"
Reply
#9
hey this is the most recent thread on the topic so here goes

I can't get the thing to boot up properly and this is the message I get from xquartz:


Code:
dyld: Library not loaded: /usr/local/lib/libgtk-x11-2.0.0.dylib
  Referenced from: /Applications/pcsx2.app/Contents/Resources/pcsx2/./pcsx2
  Reason: image not found
pcsx2.sh: line 2:  9379 Trace/BPT trap: 5       ./pcsx2

I saw someone comment on a similar error message and the recommendation was to make sure the Cg package was installed. I've tried it twice and it hasn't fixed the problem!

help plz I have no idea what I'm doin

running on Lion, 2.13 GHz Intel Core 2 Duo processor, NVIDIA GeForce 9400M 256 MB card
Reply




Users browsing this thread: 1 Guest(s)