Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with the mutli-core enhancement
#1
Hello. First, i want you to know that I'm french, so excuse my poor english plz Wink

Well, I downloaded the last version of pcsx2 (0.9.8) and I saw that the multi-core processor could improve the framerate.

I have an intel I5 processeur, and on my desktop, i have a tool (on seven) which shows my % of processeur used.

Now, when I'm playing ffx-2, I have tons of lags, especially during cut-scenes (like the first one), where my fps drop to 30-35 fps, and during the cut-scenes, only fifty percent of my processor is used, is it normal?

I configured pcsx2 following the new threads, and I activated the speed hack mVU flag hack.

As my GS plugin, i chose GSdx 4600 (SSSE3) with direct 3D10 (hardware) and the native settings.

So, can you explain me how can I exoploit all my processor plz? I tried tons of modifications, nothing worked.



I have another problem too, with the fps max limit, I tried to change it in the .ini file, I save the file, but nothing changes, and when I open again the same file, the fps limit stays at 50.0... (PS: I change the value while pcsx2 is running).


Thx for your attention!
Reply

Sponsored links

#2
Pcsx2 Only uses two cores. And ffx-2 Cutscenes are some of the most cpu intensive things
[Image: 8rg00e-4.png]
Reply
#3
Pcsx2 can only use 2 cores natively, however you can enable the MTVU speedhack (not mVU Flag Hack) so pcsx2 can use one extra core on your cpu to gain some speed, I'm not sure if it was added in 0.98 so maybe check the latest revision (look on the build bot).

Depending on what I5 CPU you own it might have 2 cores or 4 , if its only has 2 cores I'm not sure that option will even help but it's worth a try.
Reply
#4
shows us your CPU and your video card via dxdiag
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
My CPU is "Intel core i5-430M".

How can I enable the MTU? I searched it but I didn't find it...

And i downloaded the version last friday, so I think I have the lattest version no?
Quote:------------------
System Information
------------------
Time of this report: 12/5/2011, 11:10:47

Operating System: Windows 7 Édition Familiale Premium 64-bit (6.1, Build 7600)
Language: French (Regional Setting: French)


BIOS: InsydeH2O Version V1.09
Processor: Intel® Core™ i5 CPU M 430 @ 2.27GHz (4 CPUs), ~2.3GHz
Memory: 4096MB RAM
Available OS Memory: 3958MB RAM
Page File: 1979MB used, 5935MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 32bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: NVIDIA GeForce GT 320M
Manufacturer: NVIDIA
Chip type: GeForce GT 320M
DAC type: Integrated RAMDAC

Display Memory: 2701 MB
Dedicated Memory: 978 MB
Shared Memory: 1723 MB
Current Mode: 1366 x 768 (32 bit) (60Hz)
Monitor Name: Moniteur Plug-and-Play générique
Monitor Model: unknown
Monitor Id: AUO22EC
Native Mode: 1366 x 768(p) (60.042Hz)
Output Type: Internal


DDI Version: 10.1
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 8/3/2011 12:50:00, 15064168 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Reply
#6
You can get the latest revision here.
http://forums.pcsx2.net/Thread-SVN-daily...-by-Orphis

Also I did a quick lookup on your cpu and it looks like it only has two cores (making it a Dual Core processor), MTVU was intended for Quad Core processors, it's still worth a try maybe it can make use of the hyperthreading.
Reply
#7
what's a "SVN"? I've never used that :s I only downloaded the full version on the website.
Reply
#8
software versioning and a revision control system, they are development builds using the very latest code available, you used to have to compile it yourself but now there is a bot that does it for you.

they are stable for the most part but are still mostly unsupported and considered beta versions.
Reply
#9
http://pcsx2.net/svn.php
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#10
which one do I choose?
Reply




Users browsing this thread: 1 Guest(s)