Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems compiling pscx2 v1.1 on Fedora
#1
Hi Gregory,

I'm trying to make a new rpm package for pcsx2 using the 1.1 fixes (r5643) that you have posted upstream (new package is to comply with Fedora packaging and also to get the fixes not included in 1.0) but I'm having issues on building even outside the packaging process:

Code:
[ 50%] Building CXX object plugins/GSdx/CMakeFiles/GSdx-0.1.16.dir/GSTextureOGL.cpp.o
/home/makerpm/pcsx2.snapshot-5643/plugins/GSdx/GSTextureOGL.cpp: In constructor ‘GSTextureOGL::GSTextureOGL(int, int, int, bool, int, GLuint)’:
/home/makerpm/pcsx2.snapshot-5643/plugins/GSdx/GSTextureOGL.cpp:125:69: error: ‘glTexStorage2D’ was not declared in this scope
/home/makerpm/pcsx2.snapshot-5643/plugins/GSdx/GSTextureOGL.cpp: In member function ‘void GSTextureOGL::EnableUnit(uint)’:
/home/makerpm/pcsx2.snapshot-5643/plugins/GSdx/GSTextureOGL.cpp:206:31: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
/home/makerpm/pcsx2.snapshot-5643/plugins/GSdx/GSTextureOGL.cpp:212:36: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
make[2]: *** [plugins/GSdx/CMakeFiles/GSdx-0.1.16.dir/GSTextureOGL.cpp.o] Error 1
make[1]: *** [plugins/GSdx/CMakeFiles/GSdx-0.1.16.dir/all] Error 2
make: *** [all] Error 2

I noticed you've applied some fixes so downloaded the latest svn (r5650), but also this stops with the same error.

Many thanks for your help - and sorry to distract you from other important development Sad
Reply

Sponsored links

#2
You need to get a newer version of this file /usr/include/GL/glext.h normally provided by mesa. And you might need to upgade glew too.

All my latest commit are in a dev branch (so no impact on trunk), but FYI I remove glew from GSdx. Beside GSdx will run on free driver (but that will be complicated to build).
Reply
#3
(06-09-2013, 06:05 PM)gregory Wrote: You need to get a newer version of this file /usr/include/GL/glext.h normally provided by mesa. And you might need to upgade glew too.

All my latest commit are in a dev branch (so no impact on trunk), but FYI I remove glew from GSdx. Beside GSdx will run on free driver (but that will be complicated to build).

the fedora packages mesa-libGL-devel provides /usr/include/GL/glext.h

fedora-updates version is 8.0.4-1, but this is installed and not solving the problem: could you tell me which version I need? I am surprised fedora repository is out of date...
Reply
#4
tsk. Yes I see now, Fedora 18 has 9.2-0.7 (I package on Fedora 17).
This is very inconvenient for building a 1.1 package for older Fedora. Anyway, thanks for your help Gregory.
Reply
#5
My advice, get an older version for the moment. I'm reworking GSdx a lot. I plan to merge my branch in a couple of week. If we still have the issue, I will import the opengl extension define in GSdx.

Future GSdx will work with open source driver. But it will require mesa 9 and you will need to build it with EGL (I need to find a solution to make it dynamic).
Reply
#6
Can you try to compile my branch with mesa 8?
svn co https://pcsx2.googlecode.com/svn/branches/gsdx-ogl-wnd
Reply
#7
I merge my branch Smile In my opinion, it would be better to package this one instead of the 1.0.

Edit: new version support opensource driver out of the box. EGL can be dropped. Tell me if you need a tarball on google code.
Reply
#8
(06-15-2013, 11:59 PM)gregory Wrote: I merge my branch Smile In my opinion, it would be better to package this one instead of the 1.0.

Edit: new version support opensource driver out of the box. EGL can be dropped. Tell me if you need a tarball on google code.

Brilliant. I''ll look forward to seeing these changes. A tarball would be great as it seems to be requirement of Fedora rpmfusion packages. I should get time to package this weekend. Smile Smile
Reply
#9
good. Can you tell me if it compile on older mesa version (ie 8.x) ?
Reply
#10
(06-18-2013, 08:23 PM)gregory Wrote: good. Can you tell me if it compile on older mesa version (ie 8.x) ?

Okay. I'll do this asap - probably will be tomorrow sometime. I Have a stack of work to do tonight unfortunately. Sad
Reply




Users browsing this thread: 1 Guest(s)