Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems running Burnout Dominator (PAL)
#1
Im trying to run the PAL version of Burnout Dominator (retail disc) but i'm having some problems. In game frame rate is a little lower than ideal (around 30 - 40) which leads to sluggishness, but a bigger problem i'm having is the screen has some sort of an overlay, there are white slightly transparant rectangles covering the screen.

My PC specs are:

AMD Phenom II X6 1090T @ 3.8ghz
Sapphire Radeon 5870 1GB
4GB DDR2 RAM

Is there anything I can do to fix these problems? If I set the video plugin to software the overlay glitch goes away, but this results in very poor framerate (around 20 fps).

A screenshot of the graphical problems:

[Image: burnoutdom.jpg]
Reply

Sponsored links

#2
i guess your "High end PC" isn't that high end after all.
Reply
#3
(05-31-2012, 07:33 PM)Squall Leonhart Wrote: i guess your "High end PC" isn't that high end after all.

Im sorry what? Its pretty high end IMO. The Phenom II is under the recommended system requirements listing and the recommended GPU is the Radeon 4750 so a 5870 should be more than capable.
Reply
#4
Have you tried the Skipdraw feature? Enable HW hacks from the video plugin and there should be a button wich leads you to more options such as Alpha, and etc.
Reply
#5
something like that happened with BO3, very slow and with those strange thick vertical blurry "lines" on pcsx2 0.9.8.. but it was fixed in the SVN ones(0.9.9).. which version are you using?
[Image: PCSX2giorgakis132-2.png]

Thanks Silver112 for the sig! ^^

Deviant: http://giorgakis132.deviantart.com/

I love violins Tongue

Reply
#6
(05-31-2012, 08:17 PM)RaTcHeT302 Wrote: Have you tried the Skipdraw feature? Enable HW hacks from the video plugin and there should be a button wich leads you to more options such as Alpha, and etc.

I will have a look cheers.

(05-31-2012, 08:25 PM)giorgakis132 Wrote: something like that happened with BO3, very slow and with those strange thick vertical blurry "lines" on pcsx2 0.9.8.. but it was fixed in the SVN ones(0.9.9).. which version are you using?

Im using 0.9.8 (the version listed under downloads on the official site). Where can I download 0.9.9 from?
Reply
#7
http://pcsx2.net/download/development/svn.html
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
(05-31-2012, 08:46 PM)jesalvein Wrote: http://pcsx2.net/download/development/svn.html

Thanks, I tried it and found setting the 'skipfix' option to 4 resolves the issue, now I can see there is some graphical corruption (pink objects and pixels in the sky) but at least its playable now.

[Image: burnoutdom2.png]
Reply
#9
Usualy that options fixes broken hud elements wich helps a lot Laugh
Reply
#10
AFAIK, if you esc the game, and then resume it, pink objects get back to normal. (at least in software mode)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)