Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pushed [Bug Report] Ape Escape 2 [NSTC-U]
#1
# PCSX2 versions used: 
  • pcsx2-v1.3.1-1256-gbbd74e5-windows-x86 (latest dev build)
  • pcsx2-v1.3.1-1199-g379adf3-windows-x86
# Emulation settings: "Safest" preset.
# Plugins used: GSdx AVX2, using the OpenGL renderer (hardware and software)
# Plugin settings: CRC Hack Level "None", with all the accurate stuff on.
# Description: 
On hardware mode, far away 3D models have their textures being cycled fast through several other game textures.
This stops as the player gets closer. On software mode this does not happen.
According to the wiki, this bug is as old as revision 1.0 r5350 and was still present in revision 1.1.0 r5517. 

# CPU: Intel® Core™ i5-4690K CPU @ 3.50GHz
# GPU: NVIDIA GeForce GTX 970 (Driver: NVIDIA 355.98)

# Screenshots:

Here's software mode, expected to be correct:

[Image: 1M94OUW.png?1]

Here's hardware mode. Notice that the building in front has the wrong texture, the left row of sunflowers is messed up, among other things.

[Image: hirx6Ri.jpg?1]

EDIT: GS dump is now attached to post #18
Reply

Sponsored links

#2
Quote:On hardware mode, far away 3D models have their textures being cycled fast through several other game textures.

That's because there is no mipmapping support in hardware mode.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(10-03-2015, 06:12 PM)Blyss Sarania Wrote: That's because there is no mipmapping support in hardware mode.

Ah, I see. Now that I've Googled a bit, I've learned that GSdx would need a rewrite to support that feature. Wouldn't have bothered to create this thread if the Ape Escape 2 wiki entry had this info, so I suggest someone with editing rights to add it there and perhaps in every other game that we know uses mipmaps.
Reply
#4
It's a wiki, anyone can edit it. Just make an account.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
It's still a valid hardware Renderer bug, pushing this to Github. once again, Thanks for the help .r5 !
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
some nitpicks:

Quote: "Safest" preset with MTVU hack

MTVU Hack isn't recommended usually since it breaks some games and causes some odd effects, please don't use MTVU hack for future bug reports, Thanks. either way, in this case it seems that the bug is also present without the MTVU hack, so it's not a problem.


Additionally, could you also try using software mode at the specific scene toggling insert key ? that would allows us to verify whether it is a Mipmap issue.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#7
Don't newer builds DEFAULT to Safest with MTVU? I think so. And if so, asking to avoid that for bug reports is pushing it a bit. Default settings should be exactly what bug reports are made with.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
Really? I guess we would have a lot Tony hawk does not work threads if mtvu would be enabled by default. Also often mtvu doesn't help a bit.
Reply
#9
new builds do not default to MTVU enabled along with Safest preset.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
Guess I was wrong Tongue2
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)