Thread Rating:
  • 5 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Qemu USB Wheel/Storage mod (Singstar test)
(02-14-2017, 10:46 PM)jackun Wrote: Ok, managed to finish downloading Mint. I'd say try to build in a bootstrapped chroot or in virtual machines for safety. 32bit packages uninstall some 64bit packages that may break some functionality probably. I updated README.md, I think I got most stuff written down there.

Edit: debootstrap zesty
Code:
sudo apt-get install debootstrap schroot
sudo debootstrap --arch=i386 zesty  ~/zesty-i386

Thanks for the new build instructions,it builds flawlessly now!

But is keyboard and mouse gonna happen or no?
Reply

Sponsored links

(02-15-2017, 06:39 PM)BitRain Wrote: But is keyboard and mouse gonna happen or no?

Probably. In another version it kind of worked on windows.
Reply
Hi, I'm having an issue that I feel like is an easy fix, but I just can't figure it out with just tinkering with settings. I have a driving force pro, everything works great, it calibrates, on the Logitech profiler the force feedback tests are perfect, but when I try this plugin there's no ffb in gt4 or in the test. That's the only thing that doesn't work. Any help?
Reply
Do the axes/buttons work otherwise? If I remember correctly, while trying to make DX's force feedback two-player friendlier I tied FFB to the wheel's steering axes. Maybe it doesn't detect the axis. OR DX doesn't bind to foreground window. Pause/resume emulator or close/reopen the conf dialog to force it rebind to window handle.

Quote:...I feel like is an easy fix...

Sadly reality doesn't care about one's feelings Laugh

Edit: ah yes, something is still missing, it only uses the first DInput device. Unplug other gamepads etc if you have any.
Reply
(03-21-2017, 09:18 AM)jackun Wrote: Do the axes/buttons work otherwise? If I remember correctly, while trying to make DX's force feedback two-player friendlier I tied FFB to the wheel's steering axes. Maybe it doesn't detect the axis. OR DX doesn't bind to foreground window. Pause/resume emulator or close/reopen the conf dialog to force it rebind to window handle.


Sadly reality doesn't care about one's feelings Laugh

Edit: ah yes, something is still missing, it only uses the first DInput device. Unplug other gamepads etc if you have any.

Yes, the steering/buttons work great inside gt4, only the ffb doesn't work. I had a xbox 360 controller connected when I was setting it all up, but unplugged it after. Would that matter as long as it's unplugged now? The only other things I have connected are my mouse, my mic, and my keyboard. Could any of those mess with this? Also, should I be using the DF/DF Pro passthrough? I have no idea what it does but I checked it because it had my wheel's name on it lol, still kind of new to all this. Thanks for your help!
Reply
Ok, I hope I got most of it fixed now. Try the dll from dist folder on github page. Passthrough _may_ work, but select 'raw input' api for that, but it might be laggy.
Reply
(03-21-2017, 09:47 PM)jackun Wrote: Ok, I hope I got most of it fixed now. Try the dll from dist folder on github page. Passthrough _may_ work, but select 'raw input' api for that, but it might be laggy.

Works beautifully now. Thanks for the quick fix!  Happy
Reply




Users browsing this thread: 1 Guest(s)