Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Quake 3 Revolution
#1
Hello, I'm not too sure if this has already been answered but the only other thread I saw the person inappropriate. This game has bad compatibility on mostly all versions however I was told that SVN r3557 had it working. Unfortuantly all the links to download have gone down. Can someone please supply me a link, or tell me a patch/code made to play with it? The game is leaglly mine (Bought) for anyone wondering Biggrin Thanks in advance

Sponsored links

#2
err.. i don't think Quake 3 Revolution has ever worked, from what i know.
[Image: 7p7vvf-6.png]
#3
It worked on PCSX2 SVN r3557. That was the only one it ever did, if someone could share or help I would greatly appreciate it!
#4
Make a proper Bug report in Bug reporting section Smile
#5
There is no game that works only one one svn.

If it doesn't work now it probably doesn't work in r3557 either.
You can take a look here
https://code.google.com/p/pcsx2/source/detail?r=3556
when quake is supposed to be fixed. Take note at the log message.

Now take a look at the r5585 Gif.cpp https://code.google.com/p/pcsx2/source/b...585&r=5585

the codes around these

gifch.tadr -= 16;
gifch.qwc = 0;

seems identical between the two revision (you can check yourself I might miss something).

The first thing you want to do is to compare the 2 Gif.cpp and see what might break this game if it does ever work in the first place.
#6
@Preet sorry about it not being in the bug spot,if you could move that would be excellent. And @abyssaldesignatorify I'll try downloading that build. I'm not really a coder, just a user, thanks for the info. As for one game only on an SVN, I don't know? Everywhere I checked online it said that SVN worked. I tried the version you sent but when I donwloaded it, it didn't work/saying that jre could not be run properly (when I have the latest version working with PCSX2 v1.0)
#7
(07-10-2013, 03:09 PM)averybomb1 Wrote: @Preet sorry about it not being in the bug spot,if you could move that would be excellent. And @abyssaldesignatorify I'll try downloading that build. I'm not really a coder, just a user, thanks for the info. As for one game only on an SVN, I don't know? Everywhere I checked online it said that SVN worked. I tried the version you sent but when I donwloaded it, it didn't work/saying that jre could not be run properly (when I have the latest version working with PCSX2 v1.0)

i can't move it.i'm not a mod
i already told u make a proper bug report
this is not proper
to see how to do it refer to bug reporting section
Here >> http://forums.pcsx2.net/Thread-Sticky-Ho...RE-posting
& then Here >> http://forums.pcsx2.net/Forum-Bug-reporting
#8
That's okay guys, There's been a fix released, thanks anyways, my problem solved Smile




Users browsing this thread: 1 Guest(s)