Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question About The GSdx and ZeroGS.
#1
Just started this whole emulating thing today so im still pretty new to all this. I did read the english guide and set all the settings to the best of my knowledge and from what i understand is that GSdx is the bees knees. Sadly PCSX2 crashes upon loading anything running as GSdx but will start when i go under ZeroGS.

My question is how much more or less GSdx compares to ZeroGS and should i worry if my computer cant use GSdx. Where im coming from is that i have a high end computer so id like all the features and better quality from GSdx since thats what its geared towards. Just wondering if im doing anything wrong or its my PC....


SPECS:

M48785TD-V EVO Motherboard
4G of DD3-1600 Memory
ATI Radeon HD 5870 1G
AMD Phenom II x4 965 Black Edition
750G 7200 RPM HD

Thank in advance for your help.
Reply

Sponsored links

#2
what error message do you exactly get ?
any screenshot ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(11-09-2010, 10:48 AM)jesalvein Wrote: what error message do you exactly get ?
any screenshot ?
Looks like disabling the AA made it work, my question is that the guide mentioned to use Scaling in GSdx (put it at the recommended 3x) and kept it at 640x480 internal res. According to the guide this will still make it 1920x1080 but when starting up it seems to be 640x480, thoughts?

So im guessing i just cant use AA or did i set something wrong in options? Adding any form of AA seems to give me the pcsx2-r3878.exe has stopped working error whenever i try to run a game.

I also experience screen shake on the emulated PS2 image when i turn frame limiter off (getting 150-200+ frames when off, 59 when on.) Guessing this can be fixed in the GSdx menu but since i didnt actually get farther than the language select i suppose i can experiment with this myself. (Fixed, fiddling with the interlacing has fixed this issue so no worries about that) Currently only concerned with the fact that I cant use any form of AA which i was really looking forward to seeing FFXII with super smooth and sleek image quality /sadface.... unless someone has a workaround or fix for me Laugh

Reply
#4
Real hardware (GPU) AA is hidden in GSdx. It has to be enabled via a hacks flag in the GSdx.ini.
It's hidden because it causes excessive memory usage, possibly crashing games fast.

Just set scaling to x3 and make sure that "Native" is not ticked.
This way you'll get a great looking FF12 and there shouldn't be any crashes.
Reply
#5
(11-09-2010, 11:57 AM)rama Wrote: Real hardware (GPU) AA is hidden in GSdx. It has to be enabled via a hacks flag in the GSdx.ini.
It's hidden because it causes excessive memory usage, possibly crashing games fast.

Just set scaling to x3 and make sure that "Native" is not ticked.
This way you'll get a great looking FF12 and there shouldn't be any crashes.
So i take it there is no workaround? Im sure that FFXII in 1080p is sweeter than playing it on the actual PS2 but I was hoping to pop a few AA.... I know about the whole Hack thing and i set allow hacks to 1 and this gave me the option in the GSdx settings to adjust it, just dont see why I cant enable it (4 flipping gigs of ram and a 400$ video card? Cmon....).

Ill still wait and hope i can figure something else out. I recall reading in the guide but cant seem to find it now for the life of me. There was a mention of overlay or maybe not (not entirely sure) but was wondering if i could do something like on FFXI where you boost the overlay res to 2-3 times your native res and have it work as a makeshift AA boost.... Its always recommended to use AA when applicable but Im not entirely sure why its crashing on me when the option is there.....

Also, I dont have native ticked so im not sure why the scaling isnt working correctly, ill fiddle with that later for now ill head to bead and hopefully get some tips by the time i wake up. Thanks for all your help guys.




Reply
#6
"4 flipping gigs of ram and a 400$ video card? Cmon...."

There's stuff money can't buy.
Stuff like an effective GS cache for GSdx that's not slow and doesn't waste memory.
Reply
#7
(11-09-2010, 06:55 PM)rama Wrote: "4 flipping gigs of ram and a 400$ video card? Cmon...."

There's stuff money can't buy.
Stuff like an effective GS cache for GSdx that's not slow and doesn't waste memory.
Seems you misunderstood where I was coming from, I'm not blaming the emulator I'm more convinced my computer is somehow the culprit. I understand the need to make a stable emulator to work on most computers rather than ones like mine. My whole thing is there is an AA option there and so I feel it would work and rather I'm doing something wrong?

I was thinking about just trying the zeroGS mode but I feel that even without the AA that GSdx mode would still run better.

Reply
#8
Figured out most of my issues, fixed the windowed issue by going into the emulation settings and went to the GS window and set it at 16:9 and enabled default to fullscreen mode on open and this got the scaling working (Im guessing so since the game itself scaled 3x at 640x480 should be giving me 1920x1080 which has left surprisingly hardly any jaggies at all). It seems that enabling the AA option in the hacked settings at all prevents the PS2 emulation itself from starting rather than the game itself (wont even go to the PS2 startup clip thingie) so im hoping in time to figure that out.

Heading off to work for the time being but when i get home i may try scaling it at 4 to 5x rather than 3x and see if that smooths the rest of the almost nonexistant jaggies. This emulator is simply amazing and id like to thank this site and its coders/modders w/e you may be called for doing such a nice thing for the PS2 playing community <:3.

AA or not ill be enjoying my FFXII UNDUB (flipping hate english dubs of FF games) with my english subtitles <;D

Reply
#9
So no one out there has a tip on a way to make the AA work??? I was able to find some guides on using nvidia cards "nhancer" to force the AA but sadly I have a ATI card and the nvidia route can only use with DX9 settings....

Also stumbled upon this issue with disabling the frame limiter, it gives me a beefy framerate but the game looks like its running at 100x speed. Any way of keeping the frame limiter off and retaining the framerate without the turbo boost in game speed?
Reply
#10
Don't disable the frame limiter then, PS2 games run at 60FPS not higher.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)