Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question about my settings (Final Fantasy X)
#1
First off, I have searched and read around this forum about a few things, but I know I've just made a mess of my settings, that seemingly work, but I know I am overdoing it..so I want to ask an opinion of people here, at least the ones who know all about settings and what not. So, to start, yes I've downloaded the latest 0.9.7 beta and plugins that came with it.

Now my specs, since this will be important too of course:

Processor: AMD Athlon 64 x2 Dual Core 2.10GHZ
Ram: 4.00GB
64 bit operating system, Windows 7 ultimate
Nvidia GeForce 8600 GT 256MB

Now I know the processor sucks, but I can play most PS2 games decently, I've been mostly playing FFX right now, it's ripped from my own disc, in iso form.

I've been playing the game well with an average of 50-58FPS or so, I hit 60 rarely but whenever I cast a spell and what not, it will dip to about 48 to 53 or so in the range. It gets bad in some areas depending on the action on screen. (Surprisingly Blitzball runs at 60FPS mostly the whole game lol)

ANYWAY, my point is, I have no idea what I'm doing with my settings, I've just turned a bunch of things on and off, and noticed I've come out with decent gameplay.

However I know I'm overdoing it with the speed hacks, but I don't know which ones I should turn off without a hit to my FPS. I know I could just turn off and on but that would take a long time and a lot of experimenting, and usually I cannot tell which ones are doing anything or nothing at all.. So I ask for help, looking at my settings, what should I turn off and on?

Yes I realize I have all speed hacks on, but hell it's been running fine with no crashes and such, FMV bug out at times but I've seen them all before anyway. Thus why am asking which ones are most likely doing nothing for Final Fantasy X. And I have VU's and stuff set to none because I could care less how it looks graphically, I care about speed mostly.

PS: Sorry for the long wall of text there, but I'm very noobish and I wanted to make my case clear and give all the basic info I could.


Attached Files Thumbnail(s)
                   
Reply

Sponsored links

#2
OK let's start with speed hacks: Definitely disable IOP cycle rate x2 since the speed increase is minimal and the breakage is considerable. I'd also turn down VU cycle stealing since it's too high and is most probably giving you false FPS readings, so even though it could be showing 55fps your real ones are about 40.

Now about VU configuration, you have it all wrong.
Quote:And I have VU's and stuff set to none because I could care less how it looks graphically, I care about speed mostly.
First, VUs have absolutely nothing to do with how the game looks or graphics Tongue

Setting clamping to None from Normal gives a moderate speedup but it WILL cause crashes/freezes later on the game so when you get them you should remember setting these back to normal (or even extra) will get you through.
Now round modes you should NOT change them. No it doesn't mean nearest is faster, they are all different behaviors of rounding numbers and the defaults are the most compatible, so set them back there.

In general you got everything that gives you speed and reduces compatibility and quality so yeah I guess you're pretty much maxed out on speed Tongue
[Image: newsig.jpg]
Reply
#3
The problem is because the particles effects those spells abuse, it's too demanding for both your CPU and Video card. The same may happen in all scenes with that effect, like areas with fire and/or sparkling objects.

Sorry but for now there is not much to do to relief the problem, try everything external to the emulator itself to relief both the CPU and GPU. Try tweaking your nvidia control panel and make sure you don't force AA and so on. Try a little application named "Game Booster" you'll find easily in the web, it is able to shutdown most 'inutile' background processes including the antivirus and able to restart them on exit.

Anything you do to help your machine can help a bit the gameplay.
Imagination is where we are truly real
Reply
#4
Ah thank you guys, other than the normal slow downs I get, it's running pretty much the same even after the settings you suggested Bositman. And yeah I told you I was a newbie to these things so I knew nothing about VU's and stuff. Tongue

I did notice when I was at the Temple of Djose, when I went to that little inn outside the temple, when I talked to an NPC it crashed on me. After your settings though I was able to talk to them normally, so thanks again. It wasn't crucial or anything and I can easily do without talking to them, but it's still welcome to know about it.

Thanks for all that again. And I never heard of that Game Booster, I'll definitely check it out.
Reply




Users browsing this thread: 1 Guest(s)