Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Question on CPU/EE usage.
#1
Core 2 Quad Q8400 @ 2.66Ghz (stock)
4GB DDR3
Radeon HD 5750
PCSX2 0.9.8

Willing to give screenshots of configuration dialogs if requested.

I noticed when playing through Kingdom Hearts that there'd be times where I'd get some slowdown, but these were rather infrequent and to be expected... however now that I'm on Kingdom Hearts II, I'm running into slowdown more often, and it causes (lasting) audio distortion/timing issues (that require a reset of the game to fix) if it goes on for more than a moment or two, so I'm curious about fixing it.

The slowdown seems to happen only in certain scenes... these are generally ones with a large viewing distance (though oddly Destiny Islands in the first game was fine), but a sure-fire way to make it happen is to combine a long draw distance with a couple high-poly models (such as a lot of characters during a cutscene).

Further confirming (in my mind) that it's a graphical issue, the EE percentage during these times is at 99-100%, compared to the 15-70% it is otherwise, and I've noticed my CPU usage spiking a bit during these scenes... but it doesn't seem to want to max out one core, is this normal?

(Screenshot of the CPU performance graph during gameplay.)

Is there any way to reduce this slowdown that doesn't involve hardware modification or improvement, or is there a way to prevent the slowdown from causing audio issues?

I could possibly record the situation with FRAPS to show you, but I think the CPU usage from FRAPS might skew the results so I'll wait for ideas.
Reply

Sponsored links

#2
Did you try any Speedhacks?
What internal res are you using?

You could try Async mode to keep the audio for lagging, too.
Reply
#3
Thanks for the post.

I have the default speedhacks applied, I haven't changed any for fear of breaking my saves/progress.

As for internal resolution, it looks like I was set on "2x Native", I'll see if the PS2 native provides any noticeable increase, though I suppose it's a tradeoff on visual quality.

If I do decide to stick with 2x native, I'll try async audio.
Reply
#4
the resolution shouldn't change anything on the EE/VU usage.
It's GS/GPU related.

Main Rig: i7-3770k @4.5ghz | 16GB DDR3 | Nvidia GTX 980 TI | Win 10 X64
Laptop: MSI GT62VR | i7-6700HQ | 16GB DDR4 | Nvidia GTX 1060 | Win 10 X64

Reply
#5
Oh, I thought the EE was the GPU, my bad...
Reply
#6
If native improves the FPS over 2x in those spots, you could try a custom res somewhere in between. Wink

You really should give the cycle sliders a try, though. Just one tick over can help a good deal, and is a way how other lower-end systems (more so your processor's clock) achieve better speeds.
Reply
#7
I'd say grab the latest SVN from here: http://pcsx2.net/svn.php
And use the new MTVU hack to take advantage of that quad core Wink
[Image: newsig.jpg]
Reply
#8
Ah, I just read about that on the front page, and it certainly seems like something I'll try, now that I've been corrected and know that it's a CPU issue, thank you!

EDIT: With the default levle-1 speedhacks plus MTVU on, I'm not actually noticing much of an improvement if any... though I notice now that the EE percentage is not at 100%, but I'm still getting slowdown (possibly more than before, down to 40FPS). And as before, it only seems to happen when the camera is facing a complex scene, as these comparisons show.

http://img812.imageshack.us/img812/8079/khslow1.png
Camera looking out at the square, slowdown.

http://img694.imageshack.us/img694/3540/khslow2.png
Turn the camera around, full speed.

EDIT2: With some checking... with MTVU enabled, I get 5 LESS FPS in that scene than with it disabled. Sad

EDIT3: And with the 0.9.8 I get 48-50FPS in that same scene, so it looks like I'll stick with 0.9.8 for now.
Reply




Users browsing this thread: 1 Guest(s)