Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVED] PCSX 0.9.8 Slowdown?
#1
[RESOLVED]

I hope this qualifies as a bug report, even though the info i can provide regarding the problem is fairly limited, and therefore, I am limited to using mainly examples.

I realized this 2 days after i got the new PCSX2. Everything looked even better since 0.9.7 beta 2, but then things got ugly. Games that used to run at perfect speeds, flawlessly fast on the betas, have now slowed down and CRAWL.

It's quite weird to explain what happens, so let me just say that i believe changes in the EE are the probable culprit, but alas i cannot be sure. Monster Hunter, Yugioh Tag Force Evolution, Dark Chronicle, these are 3 games that used to play top speed with only a few standard speedhacks on, though they didn't really need them. In 0.9.8, these games hardly ever go over 40 fps (and sometimes even videos lag), and the console shows absolutely nothing suspicious for me to report.

To fix the problem, i started experimenting. I reduced the graphics to nearly nonthing, removed sound altogether, removed speedhacks, tried gamefixes, frameskips, even messed around with the EE clamping just in case. But NOTHING solves this weird issue. I keep getting a low framerate, as if the EE is constantly bottlenecked, and lemme tell you, Yugioh Tag Force is NO heavy game to put stress on my computer.

I did notice a slight raise in the EE activity in the same game in r4600 compared to r3878, which is my only basis so far.
On the beta it runs at 50fps (PAL) with a mere 30% to 40% usage of EE and a GS usage that never goes over 10%. In the stable version, EE usage is constantly over 40%. Go figure.

I have no idea what exactly changed between the beta and the stable release, so i cannot assume accurately what is at fault here. But i plead that you look into this because i simply cannot accept that it's some new and weird bug that would only occur to me for some profound reason.

My computer specs are roughly:
AMD Phenom II X4 945 @OC 3.6ghz
ATI Radeon HD 4890
OCZ Geil 4GB RAM @800mhz 4.4.4.12

I don't think much else matters apart from those.
Need you any further info i haven't provided, or perhaps screenshots of the issue, just ask.
All i want is to use the newer version because of the compatibility, but because of this, i'm stuck with the beta. :/

[RESOLVED]
Reply

Sponsored links

#2
PCSX2 settings? Plugin settings?

Try setting your power profile in window's control panel to high performance, also try disabling or forcing off vsync in both the emulator and your graphic card's control panel.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I'd like to take a second to apologize here if i worried any of you, since i just found out what was causing the problem. I wonder myself how i didn't see it sooner, because Synchronized MTGS was active all along.

I have no idea how it ended up active in the first place, perhaps it shared some settings with the beta from when i was trying to find a workaround to the weird fog bugs in the Crash games. I know for one i didn't activate it myself for i have been messing around with settings so much i pretty much know what each and every one does and doesn't in all the games i've tried..

You can close this topic, or trash it, not important. Again, sorry if i wasted your time.
Reply




Users browsing this thread: 1 Guest(s)