Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random FPS drop is FFX [Need Major Help!]
#1
I was complaining about this earlier in the week, and it was fine the last 3 days but it returned again! After rebooting my laptop 5 times, the FPS drops appears in random spots, especially if I encounter ANYBODY in a battle. This is getting a bit ridiculous right now, is there any solution?

Some of my laptop specs:
[Image: 920aedb9039ac4011731a82566dda847.png]

Some of my settings:
[Image: 3b1214e6c6e47e27bf04b4752424ba5e.png]

[Image: 20ee7e909d7718233f67822331797a56.png]



Reply

Sponsored links

#2
Firstly, you should be using Direct3D10 (Hardware) in GSdx, it's faster than D3D9, and you might want to try the latest beta plugins too.

If you' haven't already, turn on some speed hacks. Tick the recommended ones, and set VU Cycle Stealing to 1 or 2.

Not sure how much of a difference this makes, but turning your Windows theme to basic should give a small boost since the transparent bars tend to steal a bit of the resources, and setting the power settings to...I think it's Performance, might help a bit too.

EDIT:
I'm also noticing your interlacing in GSdx says "1/2 fps". Is that halving your frame rate? Even if not halving, the blurring might be pushing your GPU a bit too. I'm not too sure about ATI/AMD cards, but to make sure (I'm pretty sure it's the CPU), what does it say for the EE and GS percentages at the top while running FFX?
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#3
Ok, I have 3D10 now. Where can I find the beta plugins?
Reply
#4
Actually, I just checked the beta thread and they don't seem to offer the plugins separately anymore. If you're running PCSX2 0.9.7.3878 (or 3876 as the emulator reports) then you probably have the last plugins they offered.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#5
more likely is in "Balanced" or "Power saver"
set to "High Performance" in the Control panel--->power options
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#6
alright. I just switched to High Performance. I'll let you guys know what happens.

edit: odd, even at high performance, its still slow. :\

EE: 24%
GS: 4-7%
Reply
#7
Ok it's definitely not your GP which I guess was obvious. BTW, that means you can crank up the internal resolution, just use the scaler, and it'll look much nicer.

Does it actually report around 24% for EE the entire time? Because if so it would have to mean you have settings somewhere slowing it down. I'm thinking you have it running in Slow Motion, which is enabled/disabled by pressing shift+tab I think. If pressing tab doesn't make it go at normal speed, go into Config > Emulation Settings, click the GS tab and set all 3 percentages under frame limiting to 100. You can just set it back to 50% for slow and 150% or 200% for turbo any time.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#8
for EE, it goes from 12 to 24% at times.

And I don't think I have it running in slow motion, because if its normal when I run around, but if I go into a battle, it goes slow. Either that, or if I even open up my menu sometimes it slows down, and if i go to my sphere grid, it slows down. It was gone for 3 days, and it came back today. I have no idea why its doing this. :\
Reply
#9
I think if you enable Allow 8-bit textures in GSdx it helps with the menus and sphere grid. Also try setting Interlacing to None and see if that helps, just enable it again if it makes no difference.

Oh and you're not running the game directly from the disc are you? That causes slow downs when the game has to seek different sections of the disc for loading.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#10
no im not running it from the disc.

and ill try the 8-bit textures and the interlacing and ill tell you if it lags or not.
Here are ALL my settings:

[Image: 09b4ac29be83d4dd8d6f4b1cb7a81e11.png]

[Image: 27c5bd46c76b2dd3f9b9799784e35f10.png]

[Image: 8d5a16834b272ef97dcbe25abd0cf72a.png]

[Image: e29872ceaab5b100f6804f38fc6469f4.png]

[Image: f02fbbeaab17a6c39f773ae2f8ecc911.png]

[Image: 943fd22ee1bc15a8dd0e4b982a15cdcd.png]

[Image: c7cbc87442a2a1920a2e3ddd00487dc0.png]

edit: this is getting ridiculous. rebooted again, and i get 15 fps. this is pissing me off. :\
Reply




Users browsing this thread: 1 Guest(s)