Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random Lag Moments in KH2
#1
Okay, so I've been playing Kingdom Hearts 2 for the past few minutes, and it seemed to be going fine. It wasn't until I had to do that shop quest where the FPS rate started to drop, and with it the animation--it began to lag.

Okay, so here are my computers specifications:

Operating System: Windows 8.1 64-bit (6.3, Build 9600)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Inspiron 5520
BIOS: A14
Processor: Intel® Core™ i5-3210M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8062MB RAM
DirectX Version: DirectX 11

Graphics Card: Intel® HD Graphics 4000

I've played the US and PAL versions of FFX successfully on this PC. I would play on the desktop, but I tend to want to play while having this PC on my lap and travel purposes. I mean, if I wanted, then I'd just use my PS2 for cord purposes. Well, nonetheless, I have the US ISO file of Kingdom Hearts 2, straight from the game I own, and was wondering why the sudden lag? I've tried many ways to fix this, looked up for help, and watched a few videos. I can't seem to find the solution.

Also, I'm using the latest version of PCSX2 considering I just downloaded the program about two weeks ago. It's been working fine up until this point.

Anyways, sorry for the long post, I didn't mean to make it that way.

PS: I have all the settings at default. That is, I haven't changed any settings since I re-downloaded the program for this specification. I didn't know what I screwed up when changing the settings, so I went ahead and uninstalled/re-downloaded the program to have it back to when it was working fine.
Reply

Sponsored links

#2
(01-30-2014, 10:00 PM)AWorldImagined Wrote: Okay, so I've been playing Kingdom Hearts 2 for the past few minutes, and it seemed to be going fine. It wasn't until I had to do that shop quest where the FPS rate started to drop, and with it the animation--it began to lag.

Okay, so here are my computers specifications:

Operating System: Windows 8.1 64-bit (6.3, Build 9600)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Inspiron 5520
BIOS: A14
Processor: Intel® Core™ i5-3210M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8062MB RAM
DirectX Version: DirectX 11

Graphics Card: Intel® HD Graphics 4000

I've played the US and PAL versions of FFX successfully on this PC. I would play on the desktop, but I tend to want to play while having this PC on my lap and travel purposes. I mean, if I wanted, then I'd just use my PS2 for cord purposes. Well, nonetheless, I have the US ISO file of Kingdom Hearts 2, straight from the game I own, and was wondering why the sudden lag? I've tried many ways to fix this, looked up for help, and watched a few videos. I can't seem to find the solution.

Also, I'm using the latest version of PCSX2 considering I just downloaded the program about two weeks ago. It's been working fine up until this point.

Anyways, sorry for the long post, I didn't mean to make it that way.

PS: I have all the settings at default. That is, I haven't changed any settings since I re-downloaded the program for this specification. I didn't know what I screwed up when changing the settings, so I went ahead and uninstalled/re-downloaded the program to have it back to when it was working fine.
Laptops are not ideal for pcsx2 and that laptop uses integrated graphics which not good but :

Make sure your laptop power plan is set to High performance.

Also download Coretemp or something similar to make sure your cpu isn't throttling. Check you temps while playing and report back.

Try enabling some speedhacks one by one.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#3
(01-30-2014, 10:00 PM)AWorldImagined Wrote: I've played the US and PAL versions of FFX successfully on this PC. I would play on the desktop, but I tend to want to play while having this PC on my lap and travel purposes. I mean, if I wanted, then I'd just use my PS2 for cord purposes. Well, nonetheless, I have the US ISO file of Kingdom Hearts 2, straight from the game I own, and was wondering why the sudden lag? I've tried many ways to fix this, looked up for help, and watched a few videos. I can't seem to find the solution.

KH2 is more demanding than FFX. Activate all recommended Speedhacks and set the internal resolution to "Native" in Gsdx. Try using the MTVU hack too but it wont bring a big speedup as your CPU has only 2 Cores + HT but it may be worth a try.
Reply
#4
Thank you everyone who has replied. Your suggestions are very wonderful. I found out the problem, though. It had nothing to do with my PC's hardware. I just forgot to put the power options at Balanced, rather than Power Saver. See, I tend to put Power Saver when I'm on the go, but I noticed with PCSX2, I need to have it at least on Balanced for it to run without lag.

Sure it eats the battery faster, but it works great with it, so I prefer that trade up.

Lastly, a personal thanks to Donovan24 for this: "Make sure your laptop power plan is set to High performance." This alone reminded me of that small, but necessary alteration. Thank you!
Reply




Users browsing this thread: 1 Guest(s)