Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random Slowdown/FPS Drops
#1
Hello,

I have been having this issue since I got pcsx2. At random times during ALL games, there will be a drop in fps with an audio lag, then 1-2 seconds later the game is back to running perfect. It seems there is no consistency in the lag, it doesn't just happen at demanding parts like new content loads, it happens completely randomly.

I have tried enabling speedhacks, running in software mode with extra rendering threads, enabling v-sync, enabling MTVU, I thought it could be my laptop overheating and my CPU downclocking, but my temperatures on my CPU never reached over 60 degrees C and I read this is very safe and not overheating.

I'd also like to mention this only happens during emulation, not PC games. I have played the witcher 2, mass effect 2, saints row 4 and many other games for hours without any lag. It only occurs during pcsx2 emulation.

Is my computer just not fast enough to run PCSX2 optimally?

SPECS:

ASUS ROG G751JL
2.6GHz - 3.6GHZ
Intel® Core™ i7 4720HQ Processor
Windows 8.1
NVIDIA® GeForce® GTX 965M with 2GB GDDR5
Reply

Sponsored links

#2
Please post your emulog.text after loading a game.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Below is the emulog.text

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
*** Device 0: 'Primary Sound Driver' (Windows DirectSound)
*** Device 1: 'Speakers (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
*** Device 3: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 4: 'Speakers (Realtek High Definition Audio)' (Windows WASAPI)
*** Device 5: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
*** Device 6: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
Opening CDVD
isoFile open ok: C:\Users\Lucas\Desktop\PCSX2 1.2.1\God of War II (USA).iso
Image type = DVD
isoFile: searching for layer1...
isoFile: loaded second layer from settings cache, sector=0x001fcc30
* CDVD Disk Open: DVD, Double layer:
* * Track 1: Data (Mode 1) (4166832 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Lucas\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Lucas\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.81;1) Game CRC = 0x2F123FD8, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
Reply
#4
I'd also like to mention I'm running my laptop on high performance mode.
Reply
#5
Tried Playing in D3D11 (hardware mode) ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
(06-04-2015, 07:15 PM)ssakash Wrote: Tried Playing in D3D11 (hardware mode) ?

Yes I have tried D3D11 and D3D9 in hardware mode.
Reply
#7
Hmm, results ? By the way, make sure to provide screenshots of all of your pcsx2 settings.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
The problem persisted in both D3D11 and D3D9. I managed to remove the audio lag by switching to AsyncMix, but the random stutter is still there. I have attached images of all of my current settings, again, I have tried many different settings within pcsx2 and none have works. The ones you see in the images are just the last ones that I've tried.


Attached Files Thumbnail(s)
                           
Reply
#9
try disabling Intel speed step in the bios and remove all the enabled gamefixes and set to automatic gamefixes.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
setting ee cycle rate & vu cycle stealing to max is a bad idea...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)