Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Random stutter with i53570 4Ghz 7950, regardless of game
#1
Hi!

First of all, major props to everyone who made it possible to run old classic ps2 titles on a pc, thank you very much.

Now I can run most games flawlessy on my system, granted a few glitches here and there, but nothing gamebreaking in my opinion. Though all games have something in common, every x time there's a certain "stutter" it's like the sound/video/game slows down for a split second, hard for me to explain it more thorough.


Running currently: pcsx2-5627-windows-x86, tried with speedhacks on/off makes no difference.

tried: pcsx2-5620-windows-x86, same thing, pcsx2-stable, same thing.

I've tried disabling/enabling a lot of options, none of them makes a difference. Now this is not gamebreaking per se, but it makes certain games feel like less fun everytime it stutters (music/action gets interrupted) oddly enough I don't have this issue at all on MGS3.

I run all my games from ISO (ripped from original), yes i've tried re-ripping copies, makes no difference, they all run great on my ps2.

Playing person 4 right now, the stutter happens like every 45 second or so if I have to take a guess, it's worse in nocturne.

Is there a way for me to turn on DEBUG, then post log if anyone is interested?

My specs:

i5 3570k 4Ghz, overclocking to 4.5Ghz makes no difference
AMD Radeon 7950 OC
8GB Ram

Thanks guys Smile
Reply

Sponsored links

#2
Only possible reasons i can think of is either CDVD read times or having a hard disk which uses Green technology or something. They tend to be annoying by conserving power and thus causing lag when they try to spin up again.
Reply
#3
(05-13-2013, 01:41 PM)Coornio Wrote: Only possible reasons i can think of is either CDVD read times or having a hard disk which uses Green technology or something. They tend to be annoying by conserving power and thus causing lag when they try to spin up again.

Thanks for the prompt reply!

No CD, running this from ISO on my hdd.

My hdd is Seagate Barracuda ST500DM002 500GB 7200 RPM RPM 16MB Cache SATA 6.0Gb/s 3.5
Reply
#4
possibly an unstable overclock, downclock it some, (to like 3.5, or whatever stock is if higher) and see if the problem still occurs
Reply
#5
This does happen sometimes when recompilation is happening, it will seem to stutter as the process is slow. Do you get anything appear in the log at the time it does it?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(05-13-2013, 02:02 PM)Saiki Wrote: possibly an unstable overclock, downclock it some, (to like 3.5, or whatever stock is if higher) and see if the problem still occurs

Tried it at stock 3,4ghz@ makes no difference Sad

(05-13-2013, 03:46 PM)refraction Wrote: This does happen sometimes when recompilation is happening, it will seem to stutter as the process is slow. Do you get anything appear in the log at the time it does it?


Hmm that's interesting. I did check the logs (window mode on to see the stutter) but there's absolutely nothing in the logs that would indicate any problems.

My fps is 60, everytime stutter occurs it goes down to 45fps for a split second then back to 60.
Reply
#7
Check both your GPU and CPU frequencies to see if there are any dips during the stutter
[Image: newsig.jpg]
Reply
#8
Try this method, it's work for me.
If you are using Nvidia card, go to Nvidia control panel and then change the power setting to "prefer maximum performance"
This fixed the random slowdown for me, not only for playing and Emulator, it fixed for playing most of PC games i.e. Super Street fighter IV AE, I think the "adaptive" in power management of Nvidia card cause this problem. because when you playing game and when your screen has manything to render, the Card has to do switching to higher performance state and this make slowingdown in a few second then then go smooth, hope this help.

edit :
Sorry, I just noticed that you are uisng ATi card, BTW I think you can give a try to change Power Control Setttings in Catalyst by rising it, lets see if this help.

ps. sorry for my english, I've try my best Smile
Reply
#9
(05-13-2013, 09:06 PM)Bositman Wrote: Check both your GPU and CPU frequencies to see if there are any dips during the stutter

Yeah that what I would have suspected my self. But no I have no throttling or anything that would explain this matter. I Just bought metro 2034 which is a very demanding game, no issues there. I can max bf 3, witcher 2 etc etc no issues only on pcsx2. Running FRAPS, constant 60fps (stutter happens for a split second) 45fps, then back to 60.

(05-14-2013, 12:06 AM)TBX Wrote: Try this method, it's work for me.
If you are using Nvidia card, go to Nvidia control panel and then change the power setting to "prefer maximum performance"
This fixed the random slowdown for me, not only for playing and Emulator, it fixed for playing most of PC games i.e. Super Street fighter IV AE, I think the "adaptive" in power management of Nvidia card cause this problem. because when you playing game and when your screen has manything to render, the Card has to do switching to higher performance state and this make slowingdown in a few second then then go smooth, hope this help.

edit :
Sorry, I just noticed that you are uisng ATi card, BTW I think you can give a try to change Power Control Setttings in Catalyst by rising it, lets see if this help.

ps. sorry for my english, I've try my best Smile

You're english is just fine sir. I'm already running full power on my desktop. I want to thank you both for taking your time helping me out. Same goes for everyone else who replied in my thread. I guess this is a problem that's only known to me with my hardware?

Like I said it's not that bad, but after a few hours it kinda alters the immersion, especially when audio skips for a second.

Weird how it seems i'm the only one affected, oh well.

Have a nice weekend!
Reply
#10
Can you try the stable version?
Reply




Users browsing this thread: 1 Guest(s)