Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rant, but problem solved
#1
I have been on and off with PCSX2 since 2011. The last time I used it intensively was precisely 2 years ago when I had built my new PC with i5-4570 and still my old Geforce 650ti. Emulation was great, I had a blast playing my favorite PS2 games for a few months. Now I wanted to play some again and I'm having a terrible experience - all games have visual glitches - lines around edges and incorrect reflections and what not. The things that have changed since 2 years ago are Windows 10 (from Win 7) and Geforce 960. I have wasted this evening trying all graphics settings, mixing them, different bios, different plugins, reinstalling PCSX2, trying older versions - nothing helps. The only mode that works well is software rendering but with it games look like I'm playing them on PS2 which is not bad but defeats the purpose of using an emulator, I could just connect my PS2 slim and have the authentic experience.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Thanks for your reply but never mind - turned out it was anisotropic filtering that was causing all the problems, I turned it off and now all is good.
Reply




Users browsing this thread: 1 Guest(s)