Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet & Clank 2
#1
This game works great for the most part. I ripped an iso from my original copy and can get about 50fps which is pretty good. However for some reason I have no audio and the game is in Spanish. Playing on the PS2 the game has options to change languages (default being english) but for some reason this iso seems to be in spanish with no option to change back to english.

Sorry if these kinds of posts are frequent. I'm new to the emulation of later consoles crowd (my experience mainly being with emulators for much older consoles). Any help would be greatly appreciated.
Reply

Sponsored links

#2
Quote:Playing on the PS2 the game has options to change languages (default being english) but for some reason this iso seems to be in spanish with no option to change back to english.
If a menu is hardcoded in the game to let you change the language, it's impossible it doesn't appear when you rip your game to iso (unless that single menu has been put on the 2nd layer of a DVD-DL , but that would be stupid from the game devs...)

did you try fuul boot instead of fast boot ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Yeah I went with full boot because that seemed like the better option but no english language selection and no audio. My choices are Spanish, Italian and French which is really dam weird because this is an English copy. I used ImgBurn to get the iso off the disk. Maybe there was something there that I selected wrong? I'm not too sure.
Reply
#4
Well, it appears to be working all of a sudden. Game is English and audio has come back. Quite a few texture glitches which I'll probably be able to solve if I just tweak the settings. No clue what made it work. I appreciate the help though.
Reply
#5
(04-05-2014, 08:45 AM)Randy Newman Wrote: Well, it appears to be working all of a sudden. Game is English and audio has come back. Quite a few texture glitches which I'll probably be able to solve if I just tweak the settings. No clue what made it work. I appreciate the help though.

The texture glitches are because GSdx(and the other plugins) don't support mip mapping in hardware mode. To fix it, press F9 while playing. But be warned: You will need a beefy system to keep it at full speed.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#6
(04-05-2014, 08:47 AM)Blyss Sarania Wrote: The texture glitches are because GSdx(and the other plugins) don't support mip mapping in hardware mode. To fix it, press F9 while playing. But be warned: You will need a beefy system to keep it at full speed.

Beefy system is almost an understatement. I know my i5 is only clocked at 3.1ghz, but it's still a pretty strong cpu. Sadly I still get slowdowns with it.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 1 Guest(s)