Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet & Clank Deadlocked (and games that also use it's engine)
#1
Hello everyone, now that mipmapping is finally on gdsx i  went to give my old ratchet & clank games a play
for now i have found 2 glitches (wich i think must be related in some way) in 2 different games (deadlocked and up your arsenal)
the one from up your arsenal happens only in one planet (and only there) when you reach the planet everything looks completely fine, all textures are loaded properly and everything, however, when you use the map or open up a vendor, when you exit those menus the textures are replaced by messy glitches or sometimes even flat colors.

the second one happens in ratchet: deadlocked and is basically the same thing, but in all planets, and since there's a menu that apears every time you try to select a mission, or whenever you have to buy anything you have to open up a vendor (or even pausing the game in deadlocked) causes this glitch

right now i'm using the following gsdx plugin:
gsdx 20170313235728 (MSVC 19.00 avx2/avx2) 1.1.0
only with the align sprite hardware hack

as far as emulation settings go i think everything is on default

My specs are:
intel i5 4690k
nvidia gtx 970


if there's anything else that i might be missing please tell me, thanks for reading the post Smile
Reply

Sponsored links

#2
Can you post your emulog from the logs folder?
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#3
(03-22-2017, 06:54 AM)CK1 Wrote: Can you post your emulog from the logs folder?

sure!


Attached Files
.txt   emuLog.txt (Size: 15,47 KB / Downloads: 26)
Reply
#4
It looks like your plugins may be mixed with an older PCSX2 revision. Download a dev build again, but don't copy anything to the new folder. Try booting the game after you reconfigure your settings and see if glitches are still present.

If that is the case, can you post some screenshots?
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
Reply
#5
sadly that wasnt the solution, but i've got some pictures now so maybe this can help.
the first one is taken just when the game gave me control
   
the second one is after pausing and unpausing the game
   
this has me baffled, i don't know why this could be happening
Reply
#6
Not 100% sure this is the same issue, but enabling the "Fast Texture Invalidation" hack prevents the pause/unpause graphical issue in Ratchet Deadlocked/Gladiator for me (at least on Catacrom Four, need to test other locations). "Disable Depth Emulation" hack also seems to achieve the same thing (earlier thread), but could potentially break some effects. Wonder why both hacks affect this issue...

Note: you must enable the hack before the issue occurs, once it has happened the only way to fix it (that I've found) is to re-boot the game.

On which planet did you encounter the problem in Ratchet & Clank 3: Up Your Arsenal?
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#7
(03-22-2017, 12:56 PM)Dreadmoth Wrote: Not 100% sure this is the same issue, but enabling the "Fast Texture Invalidation" hack fixes the pause/unpause graphical issue in Ratchet Deadlocked/Gladiator for me (at least on Catacrom Four, need to test other locations). "Disable Depth Emulation" hack also seems to achieve the same thing (earlier thread), but could potentially break some effects. Wonder why both hacks affect this issue...
Because it's a depth issue. Tongue2 If you disable depth emulation, you basically disable the issue too. That's why Direct3D is fine too.

Anyone experiencing the issue should just enable the "Fast Texture Invalidation" hack, and try to stay away from the "Disable Depth Emulation" option. Wink
Reply
#8
(03-22-2017, 01:20 PM)FlatOut Wrote: Because it's a depth issue. Tongue2 If you disable depth emulation, you basically disable the issue too. That's why Direct3D is fine too.

Yeah, I figured that Tongue2 - it's the Fast Texture Invalidation hack affecting it that I was curious about.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#9
(03-22-2017, 12:56 PM)Dreadmoth Wrote: Not 100% sure this is the same issue, but enabling the "Fast Texture Invalidation" hack prevents the pause/unpause graphical issue in Ratchet Deadlocked/Gladiator for me (at least on Catacrom Four, need to test other locations). "Disable Depth Emulation" hack also seems to achieve the same thing (earlier thread), but could potentially break some effects. Wonder why both hacks affect this issue...

Note: you must enable the hack before the issue occurs, once it has happened the only way to fix it (that I've found) is to re-boot the game.

On which planet did you encounter the problem in Ratchet & Clank 3: Up Your Arsenal?

thank you for the help!! really apreciate it!

as for ratchet and clank up your arsenal that problem happens in aquatos, but i'll check if this fixes it!
Reply
#10
Well guys, seems the issue on both games was fixed! Laugh

now the only thing that stands on the way of perfect emulation of these games is the strange lag that i get in some areas when looking certain directions
if anyoe happens to know anything about it please do tell

again thanks guys for the help Smile
Reply




Users browsing this thread: 1 Guest(s)