Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ratchet and Clank 1 for perfect 60 FPS emulation
#1
Amazing work, I thought this day would never come where Ratchet and Clank is perfectly emulated at almost constant 60fps without graphical glitches.  5x native runs nearly flawlessly for me but some dips  to the mid 50 fps can occur.  Please post if you find bugs playing with these settings because I have yet to find any that negatively affect graphics or gameplay.
Windows 7 Ultimate x64
i7-860 @ 3.53
8GB DDR3 1866
EVGA GTX1060 3GB

PCSX 1.5.0 1682
Aggressive Preset
System => Enable Widescreen Patches
GS Window => Aspect Ratio: Widescreen (16:9)
Speedhacks => EE Cyclerate = -2
                       VU Cycle Stealing = 0
                       MTVU on
GSdx Settings => OpenGL
                          SSE4.1
                          6x Native 
                          Mipmapping: Basic
                          CRC Hack Level: Partial
                          Enable HW Hacks: Align Sprites
                          Blending Unit Accuracy: Basic
Reply

Sponsored links

#2
you should crop that up in part to your cpu and gpu. not everyone has this beefy a system. I can only run it 60fps with x3.
[Image: dy6224-5.png]
Reply
#3
Nice! This works for me!

I'm using build 1749 and also turned on Blending Unit Accuracy to Basic, that fixes Ratchet's shadow with no apparent fps drop
Reply
#4
ok after playing the game for a few hours, using ryanboy's settings, the game has decent fps 95% of the time, there are some still annoying parts of the game where there are major frame drops down to 40 fps
Reply
#5
Setting the blending unit to basic might be causing the slowdowns, with my settings i sometimes get tiny dips when the camera is viewing nearly the entire map of some levels but its not enough to b a distraction IMO. If turning down your internal resolution does not fix the issue then only changing settings may help or a future version of pcsx2 that boosts performance.
Reply
#6
(01-06-2017, 03:32 AM)ryanboyl Wrote: Setting the blending unit to basic might be causing the slowdowns, with my settings i sometimes get tiny dips when the camera is viewing nearly the entire map of some levels but its not enough to b a distraction IMO. If turning down your internal resolution does not fix the issue then only changing settings may help or a future version of pcsx2 that boosts performance.

Unfortunately changing blending unit accuracy had no affect on fps
Reply
#7
Tried testing to find a difference in fps when applying blending unit to basic, but it seems you are correct in that there is no noticeable performance drop. Updating the settings to include your recommendation. Thanks for the assist.
Reply
#8
Damn my job for being such a distraction in my life. Today I discovered that changing the EE Cycle Rate to -2 eliminates all dips and provides a perfect 60fps. Not only that, I can increase the internal resolution to 8x and it runs perfectly smooth with enough headroom to take it higher, although I dont see a need for a higher internal resolution.
Reply
#9
In the starting position in Blackwater City I noticed that when I move the camera quickly left to right that the lights from the ships flying around will sometimes appear out of place for a single frame. Whether this occurs when playing on the PS2 console is unknown to me since mine broke awhile ago. Not a bug that bothers me in the slightest.
Reply
#10
Setting the EE Cycle Rate to -2 doesn't work for me, the game still slows down, but FRAPS says it's always at 60 fps
Reply




Users browsing this thread: 1 Guest(s)