Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reasonably Good Laptop but very slow preformance.
#1
So I have:
Intel i7-2630QM 2.00GHz but it goes up to 3.00GHz with turbo boost
Nvidia GeForce GT 550M
Ram: 8Gb
system type: 64-bit

I'm running PCSX2 version 1.0.0 and trying to play shadow of the colossus, but just on the opening cut scene i drop to about 20 fps. I can get the fps up a bit if i use speed hacks and go to native resolution but this is super pixelated and horrible to play. I think my setup is good enough to handle this, but I could easily be overestimating it.
Reply

Sponsored links

#2
The 2630QM is a bit outdated today. It was the first Sandy Bridge quadcore i7 to be launched by Intel, then replaced by the 2670QM @ 2.2 Ghz.

Set VU Cycle Stealing to 2, or 3 if necessary OR get a new laptop with a 8.0 Ghz CPU.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#3
That gives me a bit of a speed up but not enough to make a difference. also, i'm not sure i've ever heard of a laptop with a 8.0ghz processor
Reply
#4
(11-27-2012, 06:26 AM)RoboWarrior Wrote: That gives me a bit of a speed up but not enough to make a difference. also, i'm not sure i've ever heard of a laptop with a 8.0ghz processor

She just trying to tell you how demanding PCSX2 was in a sarcastic way. Smile
Reply
#5
Haha. I figured. its hard to tell tone in text form lol
Reply
#6
1. Make sure PCSX2 is using the Nvidia GPU and not the Intel one:
- Open the NVIDIA control panel. Menu: Desktop -> make sure 'Add "Run with graphics processor" to context menu' is checked.
- Run PCSX2 by right clicking on it (e.g. on the desktop shortcut), then "Run with graphic processor" -> "High performance NVIDIA processor".
- Alternatively, add PCSX2 to the list of programs that will use the NVIDIA GPU by default at the NVIDIA control panel.

2. Use speed hacks in PCSX2: Config -> Emulation settings -> Speed hacks:
- Choose preset 4 (5 will also work but will be less smooth, but it WILL run faster).
- Check MTVU.
- Use SuperVU: uncheck the "Preset" checkbox (settings will stay from the last preset you chose), At the "VUs" tab, select SuperVU for both VU0 and VU1.

3. At the GSdx config panel (PCSX2 menu: config -> Video (GS) -> Plugin settings):
- Choose renderer: DirectX 11 (hardware) - this is quite faster than DX9 for this game.
- Check Original PS2 resolution: Native (you can later also test with x2 resolution if it runs fast, or custom -> 256x256 if it's still slow, but it WILL suck at such low res).
- UNcheck "allow 8-bit textures" (you can later also test with it checked).


To improve visual quality with this game (unrelated to performance), at GSdx config check "Enable HW hacks" and click the "Configure" button next to it:
- To disable the over-bright bloom effect: check "Aggressive CRC".
- If you use x2 or higher resolution, also check "Alpha" and "Half pixel offset" to remove "double vision" on some objects.

I believe you should be able to play it reasonably well on this system, however, you should know that this specific game is one of the more demanding ones out there.

Good luck, and let us know if it worked.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#7
From what I have heard, Shadow of the Colossus runs at ~40 FPS on a 2500K overclocked to 4.5 Ghz (no speedhacks). So a 8.0 Ghz CPU could handle this game at full speed. Laugh

Shadow of the Colossus is one of the most CPU intensive games in PCSX2. VU Cycle Stealing speedhack gives a huge speed boost however. If it is still not enough, then you're out of luck.

If you're using PAL version, use 50 Hz mode. It depends on the game but you have a small chance of a few FPS increase.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#8
OK. so it looks like i got it to work fairly well. i used the advice from avih and set my VU's to superVU. then i used preset 4 aswell. the native resolution still looked pretty bad, but i bumped it up to 800x600 and it looks quite a bit better. i dont have framelimiting on so it is running a bit faster, but if its on it tends to lag a bit from time to time. I also used EE speed hack of 2 and VU speed hack 3.

Thanks for the help everyoneBiggrin
Reply
#9
Unless it is seriously impacting performance you should keep the framelimiting. The ideal FPS for PS2 games is 60 or 50 (depending on the region) anything below or above is "wrong" with respect the pace of the game (if wanting to speed some part of it or to slowdown, better using the Tab or Shift+Tab respectively, this is not for play the game, but may help quickily bypassing some boring part/cutscene or to help in some minigame).

And yes, that game is reported as one the most demanding on the machine.
Imagination is where we are truly real
Reply
#10
It is the most demanding game on the system. Its actually quite boring as well. They just wanted to make a game to see what the PS2 was really capable of doing and this was the result. Its like a tech demo but a full version one lol.

As for what Livy posted. An 8GHZ CPU would be extreme overkill for the game. I mean I got a 3570K at 4.1GHZ and I do not go below 40FPS. I average around 42-50 but it is a slightly better CPU than the 2500 is. So this is probably whats given the tad bit extra performance in the game from a 2500k even at 4.5GHZ mine still seems to better off even at 400mhz less speed.

I am all on native settings no AA and no speed hacks. Even with the MTVU hack on I was only maybe getting a 3-5FPS increase.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply




Users browsing this thread: 1 Guest(s)