Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Red Dead Revolver
#1
The games in r4569 seem to have similar problem to this game fixed by "CRC hackfix". Because I'm not too good with this is it possible to add this game to "try it"
More info:
http://code.google.com/p/pcsx2/issues/detail?id=942
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit

Sponsored links

#2
Try skipdraw=50 for that one, a CRC hackfix for that would just be removing the postprocess same as skipdraw I think but I'll see if it can be done better.

By the way have you been able to play that game without problems other than that? There was a cutscene in like 3rd stage or something that simply closed PCSX2 after some EE unrecognized ops and pretty difficult to skip, does that happen to you and keeps happening later?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#3
Haven't got there yet since this bug is annoying me when I use that special move, but thanks for suggestion.
Tried UserHacks_SkipDraw=50 in Gsdx.ini and no dice.
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#4
Hmmm i'm pretty sure that skipdraw=50 works, maybe you're changing the wrong file? try adding a new line "allowhacks=1" and see if the hack options appear in the GSdx settings window Tongue2

Anyways I'll see if I can make a better hackfix for it. BTW you wouldn't happen to have the PAL/NTSC-J version of it? I could use a GSdump of that Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#5
Funnily enough I have NTSC-U version and I have allowhacks=1 in the ini. Dunno what's wrong.
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#6
So you have allowhacks=1 in the ini but the hack options (alpha/skipdraw/offset hack) don't appear on the GSdx setting window?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#7
I can see them. I have DX11 Hardware and Skipdraw hack set to 50.
I figured it out. I can't use native resolution. Anything above works.
Now it doesn't work again. I am confused.
It works randomly if I switch rendering method, but I still can see top left corner having these stripes.
http://i.imgur.com/rPjA1.jpg
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#8
Thanks for the fix <3
Also since I'm playing it I know what you mean. I got past it, because older PCSX2 didn't crash there and my savegame remained untouched.
That reminds me the intro video crashes the game if you don't skip it with this in console
branch 1c1c1d1d in delay slot!
branch 1e1e1f1f in delay slot!
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
#9
Right, do you remember which versions worked with the videos?
I know 0.9.6 gave a bigger time to skip them, but in recent ones you gotta be very fast to skip them which isn't nice...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#10
Tried 0.9.4 and the game is stuck, 0.9.5 svn does the same thing. Dunno if it ever worked :/
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit




Users browsing this thread: 1 Guest(s)