Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved 1.4.0 crawling moments with OpenGL
#1
I noticed a few instances where the emulation goes from 100% speed down to 5% or something and the game almost looks like it hangs or goes in slow motion, without necessarily using 100% of the CPU. This happens in OpenGL and in order to pass those instances, i have to change to software mode with F9 (yes, in SW it runs faster)

This happens in Grand Turismo 4 when you select a car and in ZOE 2, level 2, when the "mummyhead" enemies appear.

I have an i5 4670, GTX 960 and Windows 7 SP1.

Sponsored links

#2
there's a new pull request on plans to increase the speed when using OpenGL with Blending unit accuracy : #1015
#3
The question is does it run faster without accurate blending? If yes, which level trigger the slow down.
#4
I'm quite sure it's vram related, as both of these games are known to hog it.
https://github.com/PCSX2/pcsx2/issues/576
[Image: newsig.jpg]
#5
Well it is easy to separate both issue. Is the speed issue appears in native resolution?

(note, missing vram usually crash on openGL).
#6
Yes, it's the blending accuracy option. I have it on the recommended setting (basic) and it slows down these games. Doesn't matter if i use other options to speed up, like native resolution or steal VUs. Only if i disable blending accuracy these games stop suffering from these hangs.
#7
Ok. FWIW, there is a new hack to accelerate it + a new PR that will improve the speed further. I'm not sure it will be enough. It really depends on the games. Some games can uses high with a very limited speed impact. Some games don't like it.
#8
The PR was merged, please retry a new build. And try also the new hack too.
#9
Sad 
In GT4, I have been experimenting with the fast accurate blend hack as well as accurate date on the track selection screens. The results I got were pretty interesting.

First and foremost, I have fixed the transition slowdown by disabling Hardware Depth. This setting alone kills fps in the menus and races in GT4.

Here are some other tests I conducted while on the vehicle selection screen.
Control (No Accurate Date, No Fast Blend)
Basic ~58-61fps
Medium ~57-61fps
High  ~20-37fps
Full ~20-39fps

With only Accurate Date
Basic ~53-58fps -
Medium ~ 53-58fps -
High ~ 50-55fps +
Full ~50-55fps +

With only Fast Accurate Blending
Basic ~58-61fps - No Change
Medium ~58-61fps - No Change
High ~20-39fps - No Change
Full ~20-40fps - No Change

tl;dr - Try disabling Hardware Depth and see if the slowdowns still occur. Fast accurate blending had no effect regardless; but Accurate Date might help on High/Full.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]
#10
i dunno, looks like you gained a couple of FPS with fast blending when doing high and full settings Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)