Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Ace Combat 4: Shattered Skies [ NTSC-U]
#1
Game ID SLUS20152, CRC A32F7CD0
Tested using Pcsx2 r4920, and latest plugins (Gsdx SSE4 [DX10,hw,Native], Lilypad, spu2x)
Speedhacks, and manual gamefixes were completely disabled. (Automatic Gamefixes enabled, to skip the problematic movies)

While testing this game I found out it gets a black sky in both hardware and software mode for gsdx, so messing with settings I figured out setting the Emotion Engine to interpreter mode the sky will re-appear (see screen shots).


this screen shot is with EE set to interpreter mode (game looks almost perfect (there is still some gfx bugs but minor compared to normal) also takes a big fps hit)
[Image: cC2pH.jpg]

this is with the EE set to recompiler (default) (game is full speed but no sky)
[Image: yGvB8.jpg]

Sponsored links

#2
Thanks for the report, we will look in to this Smile wierd ones can be fun ;p
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#3
hmmm tried playing with the Clamping and/or Round modes?

Off-topic: Are you the hyakki from the JPCSP forum ? Smile

#4
(10-04-2011, 02:17 PM)andutrache Wrote: hmmm tried playing with the Clamping and/or Round modes?

Off-topic: Are you the hyakki from the JPCSP forum ? Smile

I walked through each clamp and round mode not much changed, the only option that had any noticeable effect was when the Emotion Engine was set to interpreter, since that eliminated the gs plugins as being the problem, I thought it was pretty safe to post a bug report Smile


off-topic
yeah same one.
I was testing Ace Combat X in Jpcsp, then I thought I'd retry my ps2 ac games with pcsx2 to see if anything has changed recently. Tongue2
#5
yep, good bug report Smile .

#6
Oh my.... Just set Software GSDX renderer and activate mipmapping.
GFX in this game are allready fixed, but ghost planes and invincible planes are sill buggy.
Excl The man will die, but not his ideas Excl
#7
(10-07-2011, 10:53 AM)Linear Wrote: Oh my.... Just set Software GSDX renderer and activate mipmapping.
GFX in this game are allready fixed, but ghost planes and invincible planes are sill buggy.

Did you actually test this with ace combat 4? cause I Just tried it and it still has no sky (it does help distant textures though, but does nothing for the black sky), also weren't the invincible planes (and clipping bug) only in ace combat zero and 5?
GSdx: (Software) mipmapping is now disabled.
GSdx: (Software) mipmapping is now enabled.


btw also setting EE interpreter mode on ace combat 0 ,5 will also make clouds visible in those games.
#8
Strange - I never have such problems with sky. Even in hardware GSDX mode.
All Ace Combat series graphic is OK on my system and i using Software mode (fixes ground textures and shadows)
Even clouds are volumetric Smile So check your emu, settings and hardware.
Excl The man will die, but not his ideas Excl
#9
The game looks fine here too, with the exception of texture mipmapping glitches.
There's also the problem of flying through the ground though, so it's not really playable Tongue2
#10
The game lacks all forms of collision detection it seems ;p
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)