Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Kessen 2
#1
Photo 
Quick Edit:

Excl 1-17-2014 Tested with SVN 5816, all bugs are fixed! Plays 100% | 100% Perfect Graphics | 100% Sound / Video (Use Game Fix)

Note: To remove bounding boxes around the spell 'Fireball' or 'Fireblast' turn off Texture Filtering in GSdx

Quick Edit:
Plugins Used - - -
GS: GSdx 5814 (MSVC 16.00, SSE41) 0.1.16 [GSdx32-SSE4]

Emulator Settings - - -
Set to 'Safest'
Game Fixes: Switch to GSdx to software rendering when a FMV plays
Nothing else changed.

Video Plugin Settings - - -
Native x3 (Use Native for some speed-up, but no problems with x3)
Direct3D11 (Hardware)
Nothing else changed.

* * * * *

I've noted that this may have been brought up before, however there is also 1 extra bug included with this thread post.

- The graphics attached to certain characters (i.e. long flowing beards, dresses, hanging cloth, breast area) go in all different directions. I am currently using SVN 1.1.0.5815 (and I have tested 5649 + 5694). Fixed with SVN 5815 for NTSC-U, SVN 5816 for PAL.

- The other bug is a bit harder to spot; after you win a battle (can't recall the map, it's the one with the boats for Liu Bei), Zhuge Liang will give you a status report. The text appears, but no sound is played for his dialogue. For Sun Quan, his armor creaks, but he does not speak his dialogue, while 5 seconds later, the next guy to talk -> dialogue plays. Tried to replicate it with SVN 5816, looks like it is fixed.

- Lastly, in the newest svn 5649, the confirmation buttons disappear. In svn 5645 they are there. (The Cross and Triangle are to appear when you load a game / save). I currently do not have screen shots for this bug (I reverted back); available upon request. Fixed with SVN 5694

Quick Edit: I have tried messing around with skipdraw, but with no results.
Favorite PS2 Games: Kessen II, SSX Tricky, & Mr. Mosquito
PlayStation 2: Ceramic White & Black (Original)

Sponsored links

#2
tried software mode ? (F9)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#3
(06-06-2013, 11:40 PM)jesalvein Wrote: tried software mode ? (F9)

Software mode has the same results as Hardware mode for bugs previously mentioned.
Favorite PS2 Games: Kessen II, SSX Tricky, & Mr. Mosquito
PlayStation 2: Ceramic White & Black (Original)
#4
good
this was just in order to make sure it was a valid bug report
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
#5
Update: The game is 100% Playable (with the bugs). I've included some screens that are only accessible towards the end / after the game is beaten by both opposing sides.

Also, I have tried the latest SVN 5654, I would suggest using SVN 5645 for now, since the newest version adds dash marks in between text, and you must access software mode (F9) to see the Triangle and Cross buttons on the screen. None of the bugs mentioned above are fixed in 5654. I will continue to update as newer pcsx2 versions are released.

Quick Edit: Those of you who might play through and notice lag spikes, it only happens during some spells (Gale, Meteor, Fireball) or when you are looking at the battlefield with all the units on the field. Even on the PS2, it would lag at certain parts, this is 'for the most part' normal (ironically, when the camera zooms out over-head when switching generals, it doesn't lag for me like it does on my PS2).

- Best way to circumvent this is to move the camera away from the field, or deal with it as it only lasts for 10-15 seconds (spells).

Quick Edit (6/16/2013): The newest SVN 5674 removes a lot of graphics in hardware mode, have to switch to software to see them. Including: buttons, graphics on the story-movie (the one where it shows your forces moving around with commentary). Bugs reported above still present.
Favorite PS2 Games: Kessen II, SSX Tricky, & Mr. Mosquito
PlayStation 2: Ceramic White & Black (Original)
#6
Update - Odd Dash "Bug" that Fixes Itself:

- Dashes appear between text now (both hardware and software mode) as of SVN 5694. Oddly, when I mess around with the settings: Set it to Native, x3, back to Native, etc., the dashes will go away. Noticed this only happens when messing with the emulator settings; specifically the Aspect Ratio.

If anyone can explain what might be happening that would be great; it's currently no longer adding the dashes, and I am using the same setup I was using when I had the dashes. See Attachments below.

*Note* Check first post in thread for update about the buttons disappearing (this has been re-fixed).
Favorite PS2 Games: Kessen II, SSX Tricky, & Mr. Mosquito
PlayStation 2: Ceramic White & Black (Original)
#7
Intresting to see that PS3's full software emulator suffers from EXACTLY the same bugs.
#8
Good observation.
#9
(01-08-2014, 11:44 AM)VIRGIN KLM Wrote: Intresting to see that PS3's full software emulator suffers from EXACTLY the same bugs.

Are you trying to say that Sony used source code from PCSX2?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#10
(01-12-2014, 09:11 AM)Nobbs66 Wrote: Are you trying to say that Sony used source code from PCSX2?

I have no doubt. IDA Pro can prove it.
But the point was that it's intresting because you would have more chances to track down what causes the bug.




Users browsing this thread: 1 Guest(s)