Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Multiple Games
#1
**NFS Hot Pursuit 2**

# PCSX2 version: r1888/r1972/r1998
# CPU: EERec on, VU0rec and VU1rec on, microVU0 and 1 on, MTGS on

# Plugins used:

~Graphics: GSdx r2140 SSE 4.1, Direct X 10 Hardware, D3D internal res 1280x720, windowed res 1280x720
~Sound: SPU2-X 1.3.0.2120 with default settings
~Controller: SSSPSX PAD Plugin Pressure Mod 1.6.0
~Cdvdrom: Linuz ISO CDVD 0.9.0

# Description: Massive memory leak when using hardware mode with interlacing enabled. Speed drops below 45% and almost fills all 6GB of RAM. If I disable interlacing it runs a little faster but screen is very jumpy. Software mode is 100% speed but poor quality and more prone to slowdowns at certain spots. I also have to go to "run -> execute" regardless of plugins or emulator version or game instant crashes blaming the GSdx .dll.




**Sky Odyssey**

# PCSX2 version: r976 till present, r720 is latest that will run it very bugged but runs it
# CPU: EERec on, VU0rec and VU1rec on, microVU0 and 1 on, MTGS on

# Plugins used:

~Graphics: GSdx r2140 SSE 4.1, Direct X 10 Hardware, D3D internal res 1280x720, windowed res 1280x720
~Sound: SPU2-X 1.3.0.2120 with default settings
~Controller: SSSPSX PAD Plugin Pressure Mod 1.6.0
~Cdvdrom: Linuz ISO CDVD 0.9.0

# Description: Game used to run (poorly, planes hit invisable walls etc) on PCSX2 0.9.5 I believe, starting at 0.9.6 till now the game does not start period. Gives a "DMA Ch.2 does not terminate" error over and over forever. See screen:

[Image: th_pcsx2_skyodyssey_error-1.png]




**Rumble Racing**

# PCSX2 version: r1888/r1972/r1998
# CPU: EERec on, VU0rec and VU1rec on, microVU0 and 1 on, MTGS on

# Plugins used:

~Graphics: GSdx r2140 SSE 4.1, Direct X 10 Hardware, D3D internal res 1280x720, windowed res 1280x720
~Sound: SPU2-X 1.3.0.2120 with default settings
~Controller: SSSPSX PAD Plugin Pressure Mod 1.6.0
~Cdvdrom: Linuz ISO CDVD 0.9.0

# Description: GSdx m_merge is NULL! crash as soon as any race starts. Flashes for half a second as if it was going to work. Happens with DX 9 and 10 hardware mode at any res over native, hardware mode with native checked does not crash, software mode does not crash. See screen:

[Image: th_pcsx2_rumbleracing_gsdx_mmerge_is_n.png]


Look at my sig for my system.
-Core i7 920 @ 4.01GHz
-EX58-UD4P
-OCZ 6GB PC3-14400 Platinum
-Sapphire HD 4870 1GB @ 800/1000MHz
-PCP&C Silencer 750W
-RAID 0 2x Seagate 250GB 7200.10RPM
-Windows 7 Ultimate x64

Sponsored links

#2
Game #1: GSdx bug, not PCSX2

Game #3: Try setting interlance to none in the GSdx config, if you set it to anything else it's known to cause crashes and that merger null message. Again, GSdx bug in either case
[Image: newsig.jpg]
#3
Ok, Rumble Racing will run fine with interlacing off, says GSdx m_merge is NULL! multiple times but does not crash screen is a little jumpy because of no interlacing. I guess game #2 is emulator based?
-Core i7 920 @ 4.01GHz
-EX58-UD4P
-OCZ 6GB PC3-14400 Platinum
-Sapphire HD 4870 1GB @ 800/1000MHz
-PCP&C Silencer 750W
-RAID 0 2x Seagate 250GB 7200.10RPM
-Windows 7 Ultimate x64
#4
Probably yes. It has tons of useful info in the debug so rama said he'd get it, maybe it will help us Wink About Rumble Racing, you can enable interlacing after you get in game with F5 it just crashes if you have it preset from the configuration dialog ( if i recall correctly)
[Image: newsig.jpg]
#5
game 2 you should turn off micro v0 and v1 i experenced the same crashes and once i turned them off i had no crashes
Devil May Cry 3Wackopecial Ed.
Dirge Of Cerberus:Final Fantasy 7
Final Fantasy 12
Kingdom Hearts
Kingdom Hearts 2
Kingdom Hearts RE:Chain Of Memories
#6
Requesting status update for Sky Odyssey since it looks like it works for other people. If it does, this thread can be closed
[Image: newsig.jpg]
#7
Still does not work with the latest legacy GUI r2107 or with 0.9.7.2124, using microVU or superVU does no difference. Hangs at the "Playstation 2" screen just after the bios then starts showing the console messages I posted, OP was with Vista x64 and I now have Windows 7 x64 done with a fresh format and still nothing.
-Core i7 920 @ 4.01GHz
-EX58-UD4P
-OCZ 6GB PC3-14400 Platinum
-Sapphire HD 4870 1GB @ 800/1000MHz
-PCP&C Silencer 750W
-RAID 0 2x Seagate 250GB 7200.10RPM
-Windows 7 Ultimate x64
#8
What's the region of your copy? PAL or NTSC?
Jake Stine (Air) - Programmer - PCSX2 Dev Team
#9
NTSC - SLUS 20134
-Core i7 920 @ 4.01GHz
-EX58-UD4P
-OCZ 6GB PC3-14400 Platinum
-Sapphire HD 4870 1GB @ 800/1000MHz
-PCP&C Silencer 750W
-RAID 0 2x Seagate 250GB 7200.10RPM
-Windows 7 Ultimate x64
#10
Ok for some reason Sky Odyssey will run with 0.9.6 now, though soon as I get in game the plane is in the ground on the runway and blows up in a few seconds. Whole game runs like theres alot of miscalculations, I can fraps it if needed. Into plays at about 80-90% speed with heavy flickering, see picture below,

[Image: gdgdg65d1g.th.png]
-Core i7 920 @ 4.01GHz
-EX58-UD4P
-OCZ 6GB PC3-14400 Platinum
-Sapphire HD 4870 1GB @ 800/1000MHz
-PCP&C Silencer 750W
-RAID 0 2x Seagate 250GB 7200.10RPM
-Windows 7 Ultimate x64




Users browsing this thread: 1 Guest(s)