Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] -Official 0.9.8 r4600- Any game
#1
Hi,

I checked out the new 0.9.8 and I immediately noticed this:

I can no longer resume a game, if I was in the GS Plugin Settings. I don't have the change something. Simply going there and then cancel the window is enough.

After hitting Resume, the sound returns, but with no visuals. Even the emulation window doesn't show up.

Now something interesting:
The sound is there, but no visuals. ESC no longer works, but the PCSX2 main window still accepts mouse commands. Now with remaining sound I hit System->Pause and Resume again and it works. I can resume the game.

So everytime I actually want to change resolution or texture filtering or whatever, I have to go like this:
Game is running->ESC->GS Plugin Settings->Resume->Pause->Resume.

This occurs with all three new revs of GSDX (SSE2, SSSE3, SSE4) and with absolut default settings. No prior import of older settings and no speedhacks.

This problem does not occur with any other settings. I can go to the audio settings for example and return to the game like normal.
Core i5 760 @ 4,0GHz DDR3 1600MHz 6-8-6-24-32 GTX480AMP @ Stock Thermaltake Level 10

Sponsored links

#2
Yeah, we know about it. It's a minor glitch we didn't iron out before the release Tongue2
#3
(05-04-2011, 10:10 PM)Nova eXelon Wrote: So everytime I actually want to change resolution or texture filtering or whatever, I have to go like this:
Game is running->ESC->GS Plugin Settings->Resume->Pause->Resume.

Uh no?
Just change to the main PCSX2 window while the game is running and go to GS plugin settings.

I mostly run games full screen so I do alt+tab or alt+enter (or you could double click if you have that option enabled) then change the settings with no "Esc" key involved and that way you don't have to pause or resume (unless you count opening the GS settings window as pause/resume which is automatic Tongue2).

Basically instead of:
Game is running->ESC->GS Plugin Settings->Resume->Pause->Resume.

You only need in windowed mode:
Game is running->GS Plugin Settings->Accept changes.

Or in fullscreen/maximized:
Game is running->Alt+Tab->GS Plugin Settings->Accept changes->Alt+Tab.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#4
Ah, OK.

So you can actually change settings on the fly, without stopping the emulation. Didn't no that. Sorry.
Core i5 760 @ 4,0GHz DDR3 1600MHz 6-8-6-24-32 GTX480AMP @ Stock Thermaltake Level 10
#5
i wouldn't do it too ften though Tongue even in a stable release the on the fly configs are touchy.

quite like how the video memory balloons by changing the internal res multipliers a whole bunch of times till pcsx2 crashes Laugh
#6
I don't get that here. We double checked about these kind of leaks and I'm pretty sure they're all fixed.
#7
might be an nvidia glitch, well if its not fixed for me that is. i still haven't got 0.9.8 installed but it was still doing it in the svn.

hell i usually stick to svn builds even when stable releases are out. Tongue2
#8
it doesn't happen to builds after 4600,at least not in my tests.and its not gpu related.
#9
Alright, good to know Laugh
#10
How hard would it be to implement a auto "flush" to prevent things like this from happening?
PC games usually have something like this, to avoid too much memory from being used.

I believe PCSX2 already has something like this by default while playing a game, so would it need improving to reflect on Plugin changes?


The last thing I remember is PCSX2 storing data in the page file when my Graphics Card memory usage gets too high.
Ivy Bridge 3770K @ 3.9GHz - MSI TwinFrozr GTX680 4GB...
...Nerpyderp.




Users browsing this thread: 1 Guest(s)