Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Silent Hill 2 / 3 / 4 [NTSC]
#1
CPU: Intell Quad Q6600 2.4 ghz (Can play Kindom Hearts / KH 2 with 4x AA on 1024 x 768 rez with a FPS of 60, no speed hacks.)
Ram: 4gb DDR2
Graphics: Nvidia 8800 GT
OS: Vista Ultimate 64-bit (Have to run PCSX in admin mode)
PCSX ver. [Beta] 0.9.7.0 - r1888
Plugin's:
ZeroGS 0.97.1
SPU2-X r2693 1.4.0
LilyPad svn (r2591) 0.10.0
cdvdGigaherz (r2361) 0.8.0
Bios: USA v02.30
Setup pics:
Speed hacks: http://yfrog.com/6wspeedlj
Sound: http://yfrog.com/0ssoundxj
Graphics: http://yfrog.com/jygraphicstj
CPU: http://yfrog.com/izcpulaj

Speed hacks: None

I have been having some trouble with these games. Silent Hill 2 and 3 mess up right from the start. The konami tag is split in 2 by a big black bar. The game gets to the start screen but messes up after that too. [Pics: http://yfrog.com/j4silenthill2startj & http://yfrog.com/2ssilenthill2j ] Only posting pics of Silent Hill 2 cause Silent Hill 3 does the exact same thing. As you can see though there are no errors in the console. So I'm not to sure what is happening, maybe a memleak?

With Silent hill 4 beginning is fine, Starts up konami screen, but when it goes into loading the start screen the words "Silent Hill 4 The Room" load in very slow FPS of about 1.4. Once the start menu loads it back up to 60 FPS. After pressing "New Game" it loads up the beginning cutsene which runs at 1.4 - 5 FPS and eventually crashes. I have seen people play these games on PCSX2 So i;m not to sure what I'm doing wrong here...

Sponsored links

#2
Quote:I have been having some trouble with these games. Silent Hill 2 and 3 mess up right from the start. The konami tag is split in 2 by a big black bar. The game gets to the start screen but messes up after that too. [Pics: http://yfrog.com/j4silenthill2startj & http://yfrog.com/2ssilenthill2j ] Only posting pics of Silent Hill 2 cause Silent Hill 3 does the exact same thing. As you can see though there are no errors in the console. So I'm not to sure what is happening, maybe a memleak?
You're using ZeroGS instead of GSdx.

Quote:With Silent hill 4 beginning is fine, Starts up konami screen, but when it goes into loading the start screen the words "Silent Hill 4 The Room" load in very slow FPS of about 1.4. Once the start menu loads it back up to 60 FPS. After pressing "New Game" it loads up the beginning cutsene which runs at 1.4 - 5 FPS and eventually crashes. I have seen people play these games on PCSX2 So i;m not to sure what I'm doing wrong here...
You're using ZeroGS instead of GSdx. And this is not a support forum.
[Image: newsig.jpg]
#3
(05-06-2010, 07:24 PM)Bositman Wrote:
Quote:I have been having some trouble with these games. Silent Hill 2 and 3 mess up right from the start. The konami tag is split in 2 by a big black bar. The game gets to the start screen but messes up after that too. [Pics: http://yfrog.com/j4silenthill2startj & http://yfrog.com/2ssilenthill2j ] Only posting pics of Silent Hill 2 cause Silent Hill 3 does the exact same thing. As you can see though there are no errors in the console. So I'm not to sure what is happening, maybe a memleak?
You're using ZeroGS instead of GSdx.

Quote:With Silent hill 4 beginning is fine, Starts up konami screen, but when it goes into loading the start screen the words "Silent Hill 4 The Room" load in very slow FPS of about 1.4. Once the start menu loads it back up to 60 FPS. After pressing "New Game" it loads up the beginning cutsene which runs at 1.4 - 5 FPS and eventually crashes. I have seen people play these games on PCSX2 So i;m not to sure what I'm doing wrong here...
You're using ZeroGS instead of GSdx. And this is not a support forum.

Sorry sort considered this a bug / glitch. My bad. Won't happen again.
#4
Silent Hill 2 and Silent Hill 3 [NTSC]

# PCSX2 version: PCSX2 0.9.7.r3876
# CPU options: All options on
# Plugins used:
[Image: 2isjqt2.png]

Also attempted to try ZeroGS, which just made a sort of garbled double display (a copy of the top half of the screen displayed on the bottom) and native PS2 res with GSdx plug in resulted in the same problem as the settings in the image. Also tried different aspect ratios, still same issue.

# Description: Both games work / run well framerate wise, but have the same serious graphic glitches. The game display is "squashed" to the top half of the screen at the title screen, and during game play, there is some strange stretching at the bottom half of the screen, while the top half displays just fine. Also Silent Hill 3 has some strange lighting glitches with the flashlight. Nothing gameplay hindering, but the shadows seem to display directly on top of objects rather than around them. The FMVs in both games seem to display with the same "squashed" effect, except they display with a strange dot/line effect.

Screenshots of the issues:
Silent Hill 2 title screen
Silent Hill 2 opening FMV shot
Silent Hill 2 intro restroom area
Silent Hill 3 title screen
Silent Hill 3 in game at Amusement Park first scene

No memcard attached since it happens throughout the intro and beginning areas of the games.
#5
Use an older GSdx version for these titles.
You can find an archive here: http://forums.pcsx2.net/Thread-GSdx
#6
(01-06-2011, 10:31 AM)rama Wrote: Use an older GSdx version for these titles.
You can find an archive here: http://forums.pcsx2.net/Thread-GSdx

Tried going through the list of posted GSdx versions, but none seem to work properly. Either they bring up an unsupported message, play full screen properly, but display the title screen overbright and then crash as soon as the game starts, or have the same problem as the current plugin.

I could check the current official build of PCSX2 though.
#7
Yea, if they're unsupported, you'll have to use an older PCSX2 version.
Try the first beta 0.9.7 from here:
http://code.google.com/p/pcsx2/downloads...-setup.exe
#8
Got it, i'll give that a shot.
#9
Results with the first beta + GSdxv1-14

Both games worked full screen with minimal graphic glitches. The FMVs on both are still messed up display wise, but the in game graphics in Silent Hill 2 display fine, albeit with white lines going down the screen (that may be due to scaling in the first beta/early plugin, since native res didnt have the lines). Silent Hill 3 displayed fine in game, aside from some similar lighting glitches that occur with the current beta build. Neither game had the stretching issue though. Although the games displayed properly during gameplay, better performance with the current plugin/beta.

Screenshots:

Silent Hill 2 in game with first beta+ GSdxv1-14

Another in game SH2 shot
#10
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
ATI Radeon R9-280 3GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)




Users browsing this thread: 1 Guest(s)