Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved-Workaround [Bug Report] Amored Core 2 (NTSC-U)
#1
Emulator version tested with: v1.3.1-8-gf88bea5 and official 1.2.1

Emulator Config Options:
No speed hacks.

EE/IOP:
Recompiler
Clamping mode- Normal, Full

VU:
Interpreter, MicroVU Recompiler, SuperVU
Clamping - Normal, Extra preserve sign
Round mode - chop/zero

Plugins: Default included in the builds
GSdx - Tested both hardware and software mode in Gdsx.
SPU-2 - xaudio 2

Bug Description: Certain audio effects start looping when in a mission and it gets progressively worse throughout. It never goes away even keeps looping when going back to the main menu.
You can see it happen around 1:30 then 2:20



Sponsored links

#2
What happens if you play with spu2-x settings?
Which synchronization mode did you use? What happens if you use the other one?
Does the same happen with the latest stable release?

Btw:
If you see bugs please don't use savestates until the problem is resolved. Always use memcard saves.
#3
I've done my testing by using fast boot everytime I've made a change and loading the memory card again and not using save states.

I've tried using the latest stable build (1.2.1) as well with various settings and it still occurs.

I've tried testing synchronizing mode to Async mix and Time Stretch but i get the same behavior with both.
#4
Are you using any cheats ? Could you reproduce the issue again by loading from memory card rather than loading from save states ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#5
I'm not using save states as i'm loading from a memory card every time after using fastboot. The bug is consistent and repeatable as I've yet to make it though the level without the sound loop bug persisting.

I'm not using any cheats or widescreen patches.
#6
I believe this game needs software mode to be played properly, make sure you have set software mode in the gsdx plugin settings rather than cycling through modes with the F9.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#7
(02-20-2015, 05:56 AM)ssakash Wrote: I believe this game needs software mode to be played properly, make sure you have set software mode in the gsdx plugin settings rather than cycling through modes with the F9.

It seemed fine back when I tested it for your budget pc thread.

(02-19-2015, 07:22 AM)Yourgrandma Wrote: Emulator version tested with: v1.3.1-8-gf88bea5 and official 1.2.1

Emulator Config Options:
No speed hacks.

EE/IOP:
Recompiler
Clamping mode- Normal, Full

VU:
Interpreter, MicroVU Recompiler, SuperVU
Clamping - Normal, Extra preserve sign
Round mode - chop/zero

Plugins: Default included in the builds
GSdx - Tested both hardware and software mode in Gdsx.
SPU-2 - xaudio 2

Bug Description: Certain audio effects start looping when in a mission and it gets progressively worse throughout. It never goes away even keeps looping when going back to the main menu.
You can see it happen around 1:30 then 2:20

Does it happen throughout the game, or is it just a certain level?
#8
I can't say it happens with every mission but it does happen with a lot of them. I've just tested 8 missions and it happened on 6 of them. Some are much worse then others though.

Software mode from boot doesn't seem to help, I've tried both dx9/11 versions (if theres a difference) and I'm still getting it.
#9
Can you please post the full emulog after the problem occured?
#10
Quote:VU:
Interpreter, MicroVU Recompiler, SuperVU

What do you mean by this? Are you saying you tried all 3?

Have you tried with just the default settings for EE and VU? (Recompiler on the EE tab, and microVU Recompiler on the VU tab)
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)




Users browsing this thread: 1 Guest(s)