Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved-Workaround [Bug Report] Timesplitters: Future Perfect [NTSC]
#1
Specifications: AMD Phenom II 550 x2 BE oc'ed @3.6GHz, GTS 250 w/512mb oc'ed 800/2000/1150, 5 GB DDR2 RAM
PCSX2 versions: r3113, r3878, r4600, r4713
CPU Options: Everything on Default
Plugins Used: GSDX r3068, r3693, r4600, r4727 on DX9/10 Hardware Mode
Everything Else on Default
Issue: I have been able to play all aspects of the game up until I try the story mode, on every version of pcsx2 I have, when finished with the first level, the game locks up. I all ways play it on hard and there is no other issues besides the game locking up on story mode. I have tried with and without speedhacks and gamefixes w/no avail. I've looked at the log and it freezes up without posting any error signs.

Sponsored links

#2
Don't know anything about this game in particular, but I'll take a shot in the dark:

Have you tried using SuperVU or Interpreter mode?

I didn't see this game in particular on the official compatibility list, although the series itself seems to be pretty compatible.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
#3
I've used SuperVu mode in the older versions of PCSX2 but to no avail. The Interpreter mode is too slow to run it.
#4
Hmm, strange.

I've managed to play through the entire story mode without too many issues a while ago.
Suppose it doesn't hurt if I try again on recent PCSX2 Builds Tongue2 (I'll give it another go shortly)

However, I'm aware this game can suck quite a bit of Graphics Memory.
Have you tried playing the game in lesser Scaling? Native Resolution? Or even Software Mode?

Update: Yeah, it still works fine.

[Image: 1h31j5on.hob.png]

Yeah, try to drop the GSDX Resolution if possible...and you may get somewhere Wink

Update: I've just tried setting it to "Native Resolution", and my Graphics Memory Usage just about hit 650MB when the First Level of Story Mode Loaded!
Ok, that's gonna be a problem for your graphics card :/
Ivy Bridge 3770K @ 3.9GHz - MSI TwinFrozr GTX680 4GB...
...Nerpyderp.
#5
I have the Same Problem with Timesplitters 3 - PAL Version, Windows asks pcsx2 to close when I finish the first Level

There is also a Fog Issue


#6
from what NoVaX1000 said, this game seems to require a lot of gpu memory, and gsdx doesn't handle running out of memory nicely, so it crashes.
run the game in native resolution to reduce the amount of memory usage.
Check out my blog: Trashcan of Code
#7
Native+Allow 8-bit textures should help a bit.
When played it I may have used 2x native and it never reached 512mb so I didn't even notice that was happening, usually can notice it easy in my uber 512MB 9600gt Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#8
(08-04-2011, 09:35 PM)cottonvibes Wrote: from what NoVaX1000 said, this game seems to require a lot of gpu memory, and gsdx doesn't handle running out of memory nicely, so it crashes.
run the game in native resolution to reduce the amount of memory usage.

Not Really, This Game runs Full Speed on my Onboard GPU (Radeon 4200)
#9
(08-04-2011, 11:51 PM)Memory Card Wrote: Not Really, This Game runs Full Speed on my Onboard GPU (Radeon 4200)

running at full speed is not a direct indicator of memory usage.
NoVaX1000 posted the gpu mem usage that the game uses when running at 4x native resolution, and its using over 1.4gb of memory.

since his doesn't crash, and yours does, its likely because you don't have enough memory. hence you should at least try to run at native resolution as everyone has suggested instead of saying "not really" without trying anything.
Check out my blog: Trashcan of Code
#10
(08-06-2011, 01:58 AM)cottonvibes Wrote: running at full speed is not a direct indicator of memory usage.
NoVaX1000 posted the gpu mem usage that the game uses when running at 4x native resolution, and its using over 1.4gb of memory.

since his doesn't crash, and yours does, its likely because you don't have enough memory. hence you should at least try to run at native resolution as everyone has suggested instead of saying "not really" without trying anything.

Doubt it, I have 4GB of Ram, It Crash as soon as you Finish the Level.




Users browsing this thread: 1 Guest(s)