Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rogue Galaxy Help? (Slow Framerates)
#1
Hello, first time poster here in need of some help.

I grabbed a copy of PCSX2 from a mate of mine, not too long ago (TC Edition 8 i think it was) to get FFX running, Good news, it runs FFX not too badly (average of 40-60fps). However, It won't run anything else besides that, well. I've downloaded the latest version of PCSX2 from the website (0.9.6 I think it was) and started to try and get Rogue Galaxy to work. It works, but ingame I get about 25fps Sad . I do not have much experience with configuring PCSX2, but would love some insight, and/or help.
There aren't any graphical problems, however the game runs at, as I said, 25fps.

PS: My Rogue Galaxy disk is very unbalanced, so I have imaged it, and currently running it through the iso, to prevent the massive racket the CD causes.

This is my current system specs:

OS: Windows XP Professional SP3 (Build #2600)
CPU: Intel Core2 Duo T5750,  2.00 GHz, 2048 KB 
Video: NVIDIA GeForce 8600M GS (1680x1050x32bpp 60Hz)
Sound: Realtek HD Audio output
Memory: 3071MB
Connection: Intel® Wireless WiFi Link 4965AGN - Packet Scheduler Miniport @ 54.0 Mbps

These are the PCSX2 settings in configure bar:
Graphics: GSdx 890 (MSVC 15.00, SSSE3) 0.1.14 > Windowed, D3D9 Hardware, PS3.0/PS2.0 (no difference in preformance), No interlacing, NLOOP hack,Texture Filtering, Alpha Correction.
Sound: SPU2-X 1.1.0 (default settings)
Controller: Lilypad 0.10.0
CDvdrom: Gigaherz's CDVD Plugin 0.7.0

OTHER SETTINGS:
CPU: EErec, VU0rec, VU1rec, Multi Threaded GS mode (all are on), and Limit Frames.
Gamefixes: FPU / VU Add/Sub Hack, both are on
Speedhacks: I have tried Use Default, x1.5, and currently it is set at x2 Cycle Rate. INTC Sync Hack on, Enable IOP x2 Cycle Rate on.
The rest of the settings I've left as default.

PSS: I'm also trying to get Dirge of Cerberus going (borrowing a mate's disk), but it's running sluggish as well
Reply

Sponsored links

#2
both games are very CPU demanding, and your CPu is quite weak for pcsx2.

You may try speedhacks, but I doubt you'll get excellent results anyways
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Try the latest beta it might give you better results (try the VU Cycle Stealing speedhack on it) other than that try checking the "native" option in GSdx, maybe set the clamp modes in "config > advanced" to none and I wouldnt leave gamefixes enabled when you dont need them.

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
(10-08-2009, 08:22 PM)Shadow Lady Wrote: Try the latest beta it might give you better results (try the VU Cycle Stealing speedhack on it) other than that try checking the "native" option in GSdx, maybe set the clamp modes in "config > advanced" to none and I wouldnt leave gamefixes enabled when you dont need them.

http://forums.pcsx2.net/thread-3716.html


What do you mean, by "Native" option?
Reply
#5
Configure the GSdx plugin and there is a "Native" box. Of course you would know that if you even bothered reading the configuration guide.
[Image: newsig.jpg]
Reply
#6
(10-09-2009, 09:00 AM)Bositman Wrote: Configure the GSdx plugin and there is a "Native" box. Of course you would know that if you even bothered reading the configuration guide.

AHA! Found it (I missed it because it was to the side a bit) .... amazing I get full FPS now with it
Reply




Users browsing this thread: 1 Guest(s)