Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rogue Galaxy weird behaviour
#1
Hi there, I am having weird issues with Rogue Galaxy, notably FPS drops.

Yesterday I started playing again from scratch on my old 0.9.9.4938 build and had a stable 60 FPS throughout the day, played for around 4 hours. Made it to Burkaqua Village.
Before that I tested with FF XII, Kingdom Hearts II and Rogue Galaxy old completed savegames to make sure the emulator still worked and everything was fine, so I started playing.

Today I resumed my save and suddenly I am getting drops as low as 50 fps. So naturally I went and downloaded 1.2.1 r5875 and to my surprise it was even worse, 40 fps. The game runs fine at 60 fps, but when battling it drops to ~50 fps and in some wide areas ~40 fps.
Tried several different settings and even a windows performance power plan, still nothing.
0.9.9 is still better at 60 fps most of the time, even battles, dropping sometimes to 50 fps.

My pc:
Phenom II x4 940 3.0 GHz
Radeon HD 4670 GDDR3 1GB Sapphire
4GB RAM Kingston 1333 MHz
HD Sata II 7200RPM 1TB
Windows 7 64bits
Direcxt 11 (even though I can't use it, it's what dxdiag says)

PCSX2 settings (0.9.9 since those run better, but tried everything on 1.2.1):
Pre-defined 3 + MTVU
Adjust to Window 1280 x 720
Native resolution
GSdx 4928 SSE2
Direct3D10 Hardware
Texture filtering grayed
Allow 8-bit textures checked


Also the load on my CPU is never above 70% on one thread and 50% on the others, and GPU stays around 30% sometimes going to 60%.

Help would be much appreciated, thanks.
Reply

Sponsored links

#2
Older versions were less accurate than the current versions. Because games are being more accurately emulated now in recent versions, they also require more resources of your computer. That's basically the short version of why 0.9.9 could run faster. Especially Rogue Galaxy is quite a heavy game to run on PCSX2. And your CPU is somewhat weak to be honest. You need an STP of 1500 to run most games at stable 60 FPS. Your CPU scores 1039.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#3
your CPU still not up to par for pcsx2. can you able to post . the screenshot of your gsdx settings , emulation settings etc.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#4
You can try the latest dev builds from orphis build bot, they are a bit faster than the 0.9.8 version in my old core 2 duo. So, I think you might also notice some speed ups.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
Here are the images of the settings:

http://i.imgur.com/059EEkW.png
http://i.imgur.com/fFMgSRb.png
http://i.imgur.com/0OQD1wx.png
http://i.imgur.com/u6f9Vqb.png
http://i.imgur.com/r8fsx9n.png
http://i.imgur.com/rNQntja.png
http://i.imgur.com/XC8Cn1Q.png
http://i.imgur.com/6vrMFqv.png

I will try the latest orphis build and post results.
I know my CPU is not optimal but it still doesn't explain why it ran just fine yesterday, but not today.

EDIT: Tried pcsx2-v1.3.1-23-gb5612ec-windows-x86, still as bad as 1.2.1
Reply
#6
Waht are your EE% and GS% readings during slowdowns?

Please check if mtvu really improves the fps.
You can try other settings for the EE cycle rate hack and find the optimum. If you want you can also play with vu cycle stealing which fakes better readings than actual ingame fps.

Try as well clamping to none in vu settings.
Reply
#7
1) put ee and vu to 2 .
2) use native resolution
3) goto audio plugins and tick sip reverb effect (can't remember properly ) .
4) use super vu recomplier legecy .

thia will make your game speed better .but in case if you will experience more slowdown than before then put 1) value to 1 & 0.
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#8
Yeah, try what brock suggested but don't use superVU recompiler use, microVU recompiler. And, your gpu can manage something around 2X-3X native.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#9
Brock: Still same results, no change at all, tried both EE and VU on 2 and 1 and 0.

Willkuer: About 60% EE and 50% GS. MTVU doesn't actually improve a lot. Clamping to none didn't work either.
Reply
#10
Make sure to remove all the background process or applications while playing pcsx2, that's probably the best you could achieve for now.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply




Users browsing this thread: 1 Guest(s)