Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Running Persona 3 FES on PCSX2 for mac
#1
Question 
Hi, When running Persona 3 on my mac I get the following output in the X11 terminal. Any help with this would be awesome. I listed all my specs below.
Code:
<unknown>:8356): Gtk-WARNING **: Attempting to read the recently used resources file at `/Users/bmetzger/.recently-used.xbel', but the parser failed: Unexpected attribute 'modified' for element 'application'.

(<unknown>:8356): GLib-CRITICAL **: g_bookmark_file_get_size: assertion `bookmark != NULL' failed
ZZogl: Using ZZ Ogl :0.21.204
ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.4
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-BvGYjT/:0".
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 8192 for Tex_2d and 8192 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Fill bilinear blocks failed!
ZZogl: Creating effects
ZZogl: Creating extra effects
ZZogl: Shader file version is outdated! Only is log-Z possible
for a number of lines
ZZogl: using full shaders
ZZogl: initialization successful
ZZogl: Disabling MRT depth writing
ZZogl: Disabling MRT depth writing
pcsx2.sh: line 2:  8356 Segmentation fault      ./pcsx2
Running a Macbook Pro OS X 10.5.8
2.6 GHz Intel Core 2 Duo
2GB 667 MHz DDR2 SDRAM
GeForce 8600M GT 512 MB VRAM
and the current pkg for PCSX2 for mac.

Any help would be appreciated, I'd really like to play Persona 3! Laugh
Reply

Sponsored links

#2
Last time I tried, persona 3 didn't load Sad From limited initial investigation it wasn't a simple fix but I do want to play it too so I'll fix it at some point Smile
Reply
#3
(07-21-2010, 10:17 AM)zedr0n Wrote: Last time I tried, persona 3 didn't load Sad From limited initial investigation it wasn't a simple fix but I do want to play it too so I'll fix it at some point Smile

Thanks for the quick reply, yeah it looks great! It's too bad it doesn't want to run Sad
Reply
#4
I am actually having a similar error message when I try to play FFX on a Macbook Pro OS X 10.6.4:

Code:
ZZogl: Using ZZ Ogl :0.21.204
ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.2
Xlib:  extension "XFree86-VidModeExtension" missing on display "/tmp/launch-sy0hCY/org.x:0".
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 8192 for Tex_2d and 8192 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Fill bilinear blocks failed!
ZZogl: Creating effects
ZZogl: Creating extra effects
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Disabling MRT depth writing
ZZogl: using full shaders
ZZogl: initialization successful
pcsx2.sh: line 2: 10141 Segmentation fault      ./pcsx2

Even when I have downloaded and enabled ZZogl 0.21.204 and checked off 'no log-z' in the Config->Graphics menu this is showing up...any suggestions would be much appreciated.
Reply
#5
Segmentation fault is a generic message so would show up in almost all cases
Reply
#6
(07-30-2010, 09:53 AM)zedr0n Wrote: Segmentation fault is a generic message so would show up in almost all cases

So does that mean there's no way to tell what is causing the error?
Reply
#7
There was an erroneous OpenGL in pre r212 revisions that lead to segfault at the very begining. I bet on this issue.
Reply
#8
(07-30-2010, 04:44 PM)Zeydlitz Wrote: There was an erroneous OpenGL in pre r212 revisions that lead to segfault at the very begining. I bet on this issue.

Sorry to be such a noob, but is there a relatively simple way to fix an issue like that? I'm not great on the programming side of things...
Reply
#9
Zeydlitz, you are probably right, but recent revs are broken for mac(as far as I remember there was a recent rev where clamping was turned off, can't check the log now, and mac seems to require that), I also get some issues on snow leopard running slower than earlier revisions so can't get the later revs out yet.
Reply
#10
Hi,first time trying to use an emulator on my mac. Usually work with them on my windows but when I heard I could use it on my primary device I was quite happy. But have been doing anything I can to get it working and it doesn't seem to want to work.

Tried two persona games, original and FES and get this.

ZZogl: creating zerogs
ZZogl: Got Doublebuffered Visual!
ZZogl: glX-Version 1.2
Xlib: extension "XFree86-VidModeExtension" missing on display "/tmp/launch-Fp1XvE/org.macosforge.xquartz:0".
ZZogl: Depth 24
ZZogl: you have Direct Rendering!
ZZogl: Using multitexturing
ZZogl: Maximun texture size is 8192 for Tex_2d and 8192 for Tex_NV
ZZogl: Disabling MRT depth writing
ZZogl: Fill bilinear blocks failed!
ZZogl: Creating effects
ZZogl: Creating extra effects
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Disabling MRT depth writing
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: Shader file version is outdated! Only is log-Z possible
ZZogl: using full shaders
ZZogl: initialization successful
ZZogl: Disabling MRT depth writing
pcsx2.sh: line 2: 3587 Segmentation fault ./pcsx2

I have tried to do everything mentioned in this topic and downloaded all the files but it still doesn't work. Not only that, but the version 213 also does not appear in the drop downs. I only get the old version and 204. 213 refuses to appear and I am not sure if there is something I need to do on my end to get it working.

As for my computer.

Model Name: MacBook Pro
Model Identifier: MacBookPro5,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.8 GHz
Number Of Processors: 1
Total Number Of Cores: 2

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3436
gMux Version: 1.7.10

Hope you can help me out on this. I can always return to the windows version but if a fix can be found I would love to use this now. Thanks for any help you can give.

Reply




Users browsing this thread: 1 Guest(s)