Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Runs at 60FPS but slows to 18FPS when using external monitor. Help!
#1
I'm running an ASUS F550C laptop. Everything is stock. It's using the NVIDIA 720M graphics card, and also comes with the intel hd4000 chip.

I can't seem to figure this out. When I run it on just the laptop it runs perfectly. As soon as I plug it into my Television via HDMI cable to use that as the monitor the speed drops making it unplayable.

My first guess is it's using the intel chip instead of the NVIDIA one when plugged in. But my NVIDIA icon is telling me that PCSX2 is infact using it. ALso I've tried putting the settings to the LOWEST possible. IT doesn't matter how lower I make the resolution. I even set the resolution on the television extremely low. No matter what setting it seems to run very slow. I can use other emulators and plug it into HDMI with no issues. This is quite the mystery.

Even more strange is that when I unplug the HDMI, and then restart the program it runs just as slow on the lap top right after! I have to go in and reset all my settings for it to go back to normal speed. SOmething is changing an internal setting when it's plugged into the hdmi, i just need to figure out what.

Any ideas? The only reason I downloaded it was to play on the television. It's a pretty large screen and seeing PS2 with sharper than the console graphics is delightful.

Thank you!
Reply

Sponsored links

#2
you'll probably have to set a profile for pcsx2 in nvidia optimus config panel
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(09-14-2014, 10:49 AM)jesalvein Wrote: you'll probably have to set a profile for pcsx2 in nvidia optimus config panel

That was the first thing I did. When I go into Device Manager, and click on the TV display it says that the controller for it is Intel HD Graphics, and NOT Nvidia.

Does this mean that the external Display has NO access to NVIDIA? It would make sense why it glitches out PCSX2 even after its unplugged. The program still thinks it's using intel HD graphics even though it says NVIDIA. Because when plugged in it's automatically switching to INtel Graphcis chip.

Any idea's how to remedy this?
Reply
#4
My guess would be to figure out how to completely disable the on board graphics
Reply
#5
I think you can disable the Integrated GPU through Bios.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#6
Check to see if by chance you have vsync enabled on the TV monitor, possibly with a non 60 refresh rate(eg 59hz or something).
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
(09-14-2014, 09:17 PM)Blyss Sarania Wrote: Check to see if by chance you have vsync enabled on the TV monitor, possibly with a non 60 refresh rate(eg 59hz or something).

Under what settings? I don't see how this would help. The issue at hand is with the emulator. When using other emulators and plugged in to hdmi I have confirmed that nvidia is still active. But when plugged in with this emulator it auto switches to on board graphics. I have no option to switch back to nvidia even though it's still listed as using it. It's a glitch.

Is there some way to make it so it has no access to oboard graphics? I cannot disable them completely because it's using optimus so the computer needs both chips.
Reply
#8
I'm sorry, I misunderstood. I didn't see that you were certain it was using onboard graphics.

And aside from disabling your on board graphics, no I don't see a way.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply




Users browsing this thread: 1 Guest(s)